summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2018-04-02 16:30:32 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2018-04-02 16:32:55 +0200
commita33f4ce9af5554d10b29a60a73f679bb2b2dc977 (patch)
tree9f1ced1d6ee20a06b77a277d845d9ec62608e6d0 /dev-libs/libdaemon
parentapp-office/auto-multiple-choice: drop Project Perl (diff)
downloadgentoo-a33f4ce9af5554d10b29a60a73f679bb2b2dc977.tar.gz
gentoo-a33f4ce9af5554d10b29a60a73f679bb2b2dc977.tar.bz2
gentoo-a33f4ce9af5554d10b29a60a73f679bb2b2dc977.zip
dev-libs/libdaemon: drop weird generated man page
Introduced by recent Doxygen releases. Apply the same fix found in Debian, etc. Bump to EAPI=6, drop unused eclasses. Add Debian patch fixing typo that appears in man page. Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-libs/libdaemon')
-rw-r--r--dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch38
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r3.ebuild67
2 files changed, 105 insertions, 0 deletions
diff --git a/dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch b/dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch
new file mode 100644
index 000000000000..70a6a0eb931f
--- /dev/null
+++ b/dev-libs/libdaemon/files/0.14-man-page-typo-fix.patch
@@ -0,0 +1,38 @@
+Patch from Debian fixing typo that appears in man page.
+
+
+diff --git a/examples/testd.c b/examples/testd.c
+index 6557dff..f734173 100644
+--- a/examples/testd.c
++++ b/examples/testd.c
+@@ -87,7 +87,7 @@ int main(int argc, char *argv[]) {
+
+ /* Wait for 20 seconds for the return value passed from the daemon process */
+ if ((ret = daemon_retval_wait(20)) < 0) {
+- daemon_log(LOG_ERR, "Could not recieve return value from daemon process: %s", strerror(errno));
++ daemon_log(LOG_ERR, "Could not receive return value from daemon process: %s", strerror(errno));
+ return 255;
+ }
+
+diff --git a/libdaemon/dsignal.h b/libdaemon/dsignal.h
+index 1719784..4030e41 100644
+--- a/libdaemon/dsignal.h
++++ b/libdaemon/dsignal.h
+@@ -34,7 +34,7 @@ extern "C" {
+ * wish to handle with select() in your main loop with
+ * daemon_signal_init() or daemon_signal_install(). After that you
+ * should sleep on the file descriptor returned by daemon_signal_fd()
+- * and get the next signal recieved with daemon_signal_next(). You
++ * and get the next signal received with daemon_signal_next(). You
+ * should call daemon_signal_done() before exiting.
+ */
+
+@@ -54,7 +54,7 @@ int daemon_signal_install(int s);
+ */
+ void daemon_signal_done(void);
+
+-/** Return the next signal recieved. This function will not
++/** Return the next signal received. This function will not
+ * block. Instead it returns 0 if no signal is queued.
+ * @return The next queued signal if one is queued, zero if none is
+ * queued, negative on failure.
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild
new file mode 100644
index 000000000000..a0be14f76444
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.14-r3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit multilib-minimal
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-man-page-typo-fix.patch
+)
+
+src_prepare() {
+ default
+
+ # doxygen is broken with out-of-source builds
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --localstatedir=/var \
+ --disable-examples \
+ --disable-lynx \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ einfo "Building documentation"
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use doc; then
+ docinto html
+ dodoc -r doc/README.html doc/style.css doc/reference/html/*
+ doman doc/reference/man/man3/*.h.3
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+
+ if use examples; then
+ docinto examples
+ dodoc examples/testd.c
+ fi
+}