summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libdbusmenu
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libdbusmenu')
-rw-r--r--dev-libs/libdbusmenu/Manifest1
-rw-r--r--dev-libs/libdbusmenu/files/libdbusmenu-12.10.2-gtk2-signal-fix.patch36
-rw-r--r--dev-libs/libdbusmenu/libdbusmenu-12.10.2-r2.ebuild124
-rw-r--r--dev-libs/libdbusmenu/metadata.xml17
4 files changed, 178 insertions, 0 deletions
diff --git a/dev-libs/libdbusmenu/Manifest b/dev-libs/libdbusmenu/Manifest
new file mode 100644
index 000000000000..3bd215e27f44
--- /dev/null
+++ b/dev-libs/libdbusmenu/Manifest
@@ -0,0 +1 @@
+DIST libdbusmenu-12.10.2.tar.gz 735730 SHA256 9d6ad4a0b918b342ad2ee9230cce8a095eb601cb0cee6ddc1122d0481f9d04c9 SHA512 cf2e50dc3adbf35d0a4ccdd62a3efd9fae2d079b8d06e6522b70f077f89ac2cf72188e380f476e38d184b69549e90b801bf1e32174fa94bbe612dd52aec94496 WHIRLPOOL 3e75fd0bcbadcff8f4e4cd3a2be33a3aa7cf715413b1a67c5430b9420a965d64db2d988fa5c21fc42c6458ad4ed479c400b28b8a94074cb7223ab0a03ad985eb
diff --git a/dev-libs/libdbusmenu/files/libdbusmenu-12.10.2-gtk2-signal-fix.patch b/dev-libs/libdbusmenu/files/libdbusmenu-12.10.2-gtk2-signal-fix.patch
new file mode 100644
index 000000000000..6d270f1370bf
--- /dev/null
+++ b/dev-libs/libdbusmenu/files/libdbusmenu-12.10.2-gtk2-signal-fix.patch
@@ -0,0 +1,36 @@
+=== modified file 'libdbusmenu-gtk/parser.c'
+--- libdbusmenu-gtk/parser.c 2013-06-18 19:59:44 +0000
++++ libdbusmenu-gtk/parser.c 2013-11-03 02:46:23 +0000
+@@ -97,9 +97,7 @@
+ gpointer data);
+ static void item_inserted_cb (GtkContainer * menu,
+ GtkWidget * widget,
+-#ifdef HAVE_GTK3
+ gint position,
+-#endif
+ gpointer data);
+ static void item_removed_cb (GtkContainer * menu,
+ GtkWidget * widget,
+@@ -431,11 +429,7 @@
+
+ pdata->shell = menu;
+ pdata->item_inserted_handler_id = g_signal_connect (G_OBJECT (menu),
+-#ifdef HAVE_GTK3
+ "insert",
+-#else
+- "child-added",
+-#endif
+ G_CALLBACK (item_inserted_cb),
+ mi);
+ pdata->item_removed_handler_id = g_signal_connect (G_OBJECT (menu),
+@@ -1394,9 +1388,7 @@
+ static void
+ item_inserted_cb (GtkContainer *menu,
+ GtkWidget *widget,
+-#ifdef HAVE_GTK3
+ gint position,
+-#endif
+ gpointer data)
+ {
+ DbusmenuMenuitem *menuitem = (DbusmenuMenuitem *)data;
+
diff --git a/dev-libs/libdbusmenu/libdbusmenu-12.10.2-r2.ebuild b/dev-libs/libdbusmenu/libdbusmenu-12.10.2-r2.ebuild
new file mode 100644
index 000000000000..7f3e1667987d
--- /dev/null
+++ b/dev-libs/libdbusmenu/libdbusmenu-12.10.2-r2.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+VALA_MIN_API_VERSION=0.16
+VALA_USE_DEPEND=vapigen
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils flag-o-matic multilib-minimal python-single-r1 vala
+
+DESCRIPTION="Library to pass menu structure across DBus"
+HOMEPAGE="http://launchpad.net/dbusmenu"
+SRC_URI="http://launchpad.net/${PN/lib}/${PV%.*}/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug gtk gtk3 +introspection"
+
+RDEPEND="
+ >=dev-libs/dbus-glib-0.100[${MULTILIB_USEDEP}]
+ >=dev-libs/json-glib-0.13.4[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.32[${MULTILIB_USEDEP}]
+ dev-libs/libxml2[${MULTILIB_USEDEP}]
+ gtk? ( x11-libs/gtk+:2[introspection?,${MULTILIB_USEDEP}] )
+ gtk3? ( >=x11-libs/gtk+-3.2:3[introspection?,${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1 )
+ !<${CATEGORY}/${PN}-0.5.1-r200"
+DEPEND="${RDEPEND}
+ app-text/gnome-doc-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ introspection? ( $(vala_depend) )"
+
+src_prepare() {
+ if use introspection; then
+ vala_src_prepare
+ export VALA_API_GEN="${VAPIGEN}"
+ fi
+ python_fix_shebang tools
+
+ # remove reliance on custom Ubuntu hacks in old GTK+2
+ epatch "${FILESDIR}/${P}-gtk2-signal-fix.patch"
+ epatch_user
+}
+
+multilib_src_configure() {
+ append-flags -Wno-error #414323
+
+ local myconf=(
+ --disable-gtk
+ --disable-static
+ --disable-silent-rules
+ --disable-scrollkeeper
+ # dumper extra tool is only for GTK+-2.x, tests use valgrind which is stupid
+ --disable-dumper
+ $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable introspection vala)
+ $(use_enable debug massivedebugging)
+ )
+ local ECONF_SOURCE=${S}
+ econf "${myconf[@]}"
+
+ GTK_VARIANTS=( $(usex gtk 2 '') $(usex gtk3 3 '') )
+ local MULTIBUILD_VARIANTS=( "${GTK_VARIANTS[@]}" )
+ local top_builddir=${BUILD_DIR}
+
+ gtk_configure() {
+ local gtkconf=(
+ "${myconf[@]}"
+ --enable-gtk
+ --with-gtk="${MULTIBUILD_VARIANT}"
+ )
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+ econf "${gtkconf[@]}"
+
+ rm -r libdbusmenu-glib || die
+ ln -s "${top_builddir}"/libdbusmenu-glib libdbusmenu-glib || die
+ }
+ [[ ${GTK_VARIANTS[@]} ]] && multibuild_foreach_variant gtk_configure
+}
+
+gtk_emake() {
+ emake -C "${BUILD_DIR}"/libdbusmenu-gtk "${@}"
+ multilib_is_native_abi && \
+ emake -C "${BUILD_DIR}"/docs/libdbusmenu-gtk "${@}"
+}
+
+multilib_src_compile() {
+ emake
+
+ local MULTIBUILD_VARIANTS=( "${GTK_VARIANTS[@]}" )
+ [[ ${GTK_VARIANTS[@]} ]] && multibuild_foreach_variant \
+ gtk_emake
+}
+
+src_test() { :; } #440192
+
+multilib_src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ local MULTIBUILD_VARIANTS=( "${GTK_VARIANTS[@]}" )
+ [[ ${GTK_VARIANTS[@]} ]] && multibuild_foreach_variant \
+ gtk_emake -j1 install DESTDIR="${D}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}
+
+pkg_preinst() {
+ # kill old symlinks that Portage will preserve and break install
+ if [[ -L ${EROOT}/usr/share/gtk-doc/html/libdbusmenu-glib ]]; then
+ rm -v "${EROOT}/usr/share/gtk-doc/html/libdbusmenu-glib" || die
+ fi
+ if [[ -L ${EROOT}/usr/share/gtk-doc/html/libdbusmenu-gtk ]]; then
+ rm -v "${EROOT}/usr/share/gtk-doc/html/libdbusmenu-gtk" || die
+ fi
+}
diff --git a/dev-libs/libdbusmenu/metadata.xml b/dev-libs/libdbusmenu/metadata.xml
new file mode 100644
index 000000000000..85f766a03bc0
--- /dev/null
+++ b/dev-libs/libdbusmenu/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <herd>ayatana</herd>
+ <maintainer>
+ <email>ayatana-bugs@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="gtk" restrict="&gt;=dev-libs/libdbusmenu-12.10.2-r2">Enable support for GTK+2</flag>
+ <flag name="gtk3">Enable support for GTK+3</flag>
+ <flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg> for introspection</flag>
+ </use>
+ <upstream>
+ <remote-id type="launchpad">dbusmenu</remote-id>
+ </upstream>
+</pkgmetadata>