summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libexecinfo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libexecinfo')
-rw-r--r--dev-libs/libexecinfo/Manifest1
-rw-r--r--dev-libs/libexecinfo/files/libexecinfo-1.1-build.patch13
-rw-r--r--dev-libs/libexecinfo/libexecinfo-1.1.ebuild25
-rw-r--r--dev-libs/libexecinfo/metadata.xml12
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/libexecinfo/Manifest b/dev-libs/libexecinfo/Manifest
new file mode 100644
index 000000000000..0b8d6d08f00c
--- /dev/null
+++ b/dev-libs/libexecinfo/Manifest
@@ -0,0 +1 @@
+DIST libexecinfo-1.1.tar.bz2 4841 SHA256 c9a21913e7fdac8ef6b33250b167aa1fc0a7b8a175145e26913a4c19d8a59b1f SHA512 51fea7910ef6873061a25c22434ce4da724e9d8e37616a069ad0a58c0463755be4c6c7da88cd747484c2f3373909d7be4678b32a4bd91b6d9e0f74526094e92c WHIRLPOOL a915ceb897905755ac87cbd9297f47ddd20fedf033aac89896187bacc91ead40ab655069bc1ba828396fa0d7ab1af5d5eca3aacc51240f08cb7f54607252cef0
diff --git a/dev-libs/libexecinfo/files/libexecinfo-1.1-build.patch b/dev-libs/libexecinfo/files/libexecinfo-1.1-build.patch
new file mode 100644
index 000000000000..b295cf71bfd0
--- /dev/null
+++ b/dev-libs/libexecinfo/files/libexecinfo-1.1-build.patch
@@ -0,0 +1,13 @@
+Index: libexecinfo-1.1/execinfo.c
+===================================================================
+--- libexecinfo-1.1.orig/execinfo.c
++++ libexecinfo-1.1/execinfo.c
+@@ -78,7 +78,7 @@ backtrace_symbols(void *const *buffer, i
+ rval = malloc(clen);
+ if (rval == NULL)
+ return NULL;
+- (char **)cp = &(rval[size]);
++ cp = &(rval[size]);
+ for (i = 0; i < size; i++) {
+ if (dladdr(buffer[i], &info) != 0) {
+ if (info.dli_sname == NULL)
diff --git a/dev-libs/libexecinfo/libexecinfo-1.1.ebuild b/dev-libs/libexecinfo/libexecinfo-1.1.ebuild
new file mode 100644
index 000000000000..c35eb64da08c
--- /dev/null
+++ b/dev-libs/libexecinfo/libexecinfo-1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit bsdmk freebsd multilib
+
+DESCRIPTION="A library for inspecting program's backtrace"
+HOMEPAGE="http://www.freebsdsoftware.org/devel/libexecinfo.html"
+SRC_URI="mirror://freebsd/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-freebsd/freebsd-mk-defs"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-build.patch" )
+
+src_install() {
+ mymakeopts="${mymakeopts} LIBDIR=/usr/$(get_libdir)"
+ freebsd_src_install
+ dodoc README
+}
diff --git a/dev-libs/libexecinfo/metadata.xml b/dev-libs/libexecinfo/metadata.xml
new file mode 100644
index 000000000000..5d71e6fb3da7
--- /dev/null
+++ b/dev-libs/libexecinfo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>bsd</herd>
+<longdescription lang="en">
+ This is a quick-n-dirty BSD licensed clone of backtrace facility found
+ in the GNU libc, mainly intended for porting linuxish code to BSD
+ platforms, however it can be used at any platform which has a gcc
+ compiler.
+</longdescription>
+</pkgmetadata>
+