summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-11-01 20:27:12 -0600
committerJory Pratt <anarchy@gentoo.org>2020-11-01 20:29:00 -0600
commit104632d70665cdb198525ef7f98068801a0070b8 (patch)
treeb4eaa6d61463e8a3b783076a9f9c73bfea2adf4b /dev-libs/libressl
parentsys-apps/portage: Bump to version 3.0.9 (diff)
downloadgentoo-104632d70665cdb198525ef7f98068801a0070b8.tar.gz
gentoo-104632d70665cdb198525ef7f98068801a0070b8.tar.bz2
gentoo-104632d70665cdb198525ef7f98068801a0070b8.zip
dev-libs/libressl: Version bump 3.2.2
Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
Diffstat (limited to 'dev-libs/libressl')
-rw-r--r--dev-libs/libressl/Manifest1
-rw-r--r--dev-libs/libressl/libressl-3.2.2.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-libs/libressl/Manifest b/dev-libs/libressl/Manifest
index d3f055151f26..03e1e6b58f77 100644
--- a/dev-libs/libressl/Manifest
+++ b/dev-libs/libressl/Manifest
@@ -4,3 +4,4 @@ DIST libressl-3.1.3.tar.gz 3766345 BLAKE2B 4956fa0ae6030e9e9969d584db3bc0084c4b1
DIST libressl-3.1.4.tar.gz 3767238 BLAKE2B e639349e50f985360f2cef01b16b5c8f3c725d4a9bbee1117787174e4de6eb9b14cc8ad5f1704971057dd0f5000eea01f3b172178c534c70d38921418034d94c SHA512 77a53c4294fc332006502dc3af069346e2c9efc9240de7f91eb48e89043525900b5b23652cfd159221c3a482cc01e263611adb752e23b707f965156e3a7cd895
DIST libressl-3.2.0.tar.gz 3775925 BLAKE2B 99d74fad16e272be8e3b23b873c35970ce3693e088baf365670ad8e8cbb846e90f4232bbc6c65b70a35060da99b9b210b3debce1c78d531e810de26e3e2f05cb SHA512 e8bf95af4e4e855b0462eb12df8f802102a3bee5bb40fb1859e7c40d9e3ce89f0d2eb0acdd923e7c592b4aeb7ecc556f753c0a12d0dace05d2ef342bffdd9d07
DIST libressl-3.2.1.tar.gz 3798341 BLAKE2B 25d4d0fa758d92fd781f39000e631d7cec0a5a8210b2b127b7d49ef0e96e1a20a45f60e6231dcbe379f57f19c1ca8a4dde6205b1cc52ee44d17a4a21da34c98a SHA512 0204177ad0291f3fce4c77ab21cce17785d0239f2ae4be8fbdce5575cc98775186caa0e1851b211c05be07e3cc603111eeaac4379c8977e7b140fedee2551f93
+DIST libressl-3.2.2.tar.gz 3839529 BLAKE2B b5c35c85bf9914b49d828963e5089e77ec0b370227f8e36c70eac9a4c9176e90ebec1dccd19fc4d99d58caaba545b78cc5570751bd73a7488e502a9bcca2c5ed SHA512 708f347ec88f0501b5937f1efc8dc15e76a2f99a54f024e21a006349abc9305f64796f7df9fcbc875e13f999a620253b62b138d76f67586f1e432f3956da25e1
diff --git a/dev-libs/libressl/libressl-3.2.2.ebuild b/dev-libs/libressl/libressl-3.2.2.ebuild
new file mode 100644
index 000000000000..ab31f2041689
--- /dev/null
+++ b/dev-libs/libressl/libressl-3.2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal libtool
+
+DESCRIPTION="Free version of the SSL/TLS protocol forked from OpenSSL"
+HOMEPAGE="https://www.libressl.org/"
+SRC_URI="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/${P}.tar.gz"
+
+LICENSE="ISC openssl"
+# Reflects ABI of libcrypto.so and libssl.so. Since these can differ,
+# we'll try to use the max of either. However, if either change between
+# versions, we have to change the subslot to trigger rebuild of consumers.
+SLOT="0/48"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+asm static-libs test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( static-libs )"
+
+RDEPEND="!dev-libs/openssl:0"
+DEPEND="${RDEPEND}"
+PDEPEND="app-misc/ca-certificates"
+
+src_prepare() {
+ touch crypto/Makefile.in
+
+ sed -i \
+ -e '/^[ \t]*CFLAGS=/s#-g ##' \
+ -e '/^[ \t]*CFLAGS=/s#-g"#"#' \
+ -e '/^[ \t]*CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*CFLAGS=/s#-O2"#"#' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2 ##' \
+ -e '/^[ \t]*USER_CFLAGS=/s#-O2"#"#' \
+ configure || die "fixing CFLAGS failed"
+
+ if ! use test ; then
+ sed -i \
+ -e '/^[ \t]*SUBDIRS =/s#tests##' \
+ Makefile.in || die "Removing tests failed"
+ fi
+
+ eapply "${FILESDIR}"/${PN}-2.8.3-solaris10.patch
+ eapply_user
+
+ elibtoolize # for Solaris
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable asm) \
+ $(use_enable static-libs static)
+}
+
+multilib_src_test() {
+ emake check
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}