summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-12-23 15:39:48 +0200
committerAlon Bar-Lev <alonbl@gentoo.org>2015-12-23 15:49:48 +0200
commit75099c61ad835d4e283e5f02af17918f7d5a6b76 (patch)
treea97fdf1b07eacfb6dfa1f9a0c5428a22760839cd /dev-libs/opencryptoki
parentdev-libs/botan: version bump (diff)
downloadgentoo-75099c61ad835d4e283e5f02af17918f7d5a6b76.tar.gz
gentoo-75099c61ad835d4e283e5f02af17918f7d5a6b76.tar.bz2
gentoo-75099c61ad835d4e283e5f02af17918f7d5a6b76.zip
dev-libs/opencryptoki: version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-libs/opencryptoki')
-rw-r--r--dev-libs/opencryptoki/Manifest1
-rw-r--r--dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild101
2 files changed, 102 insertions, 0 deletions
diff --git a/dev-libs/opencryptoki/Manifest b/dev-libs/opencryptoki/Manifest
index 9f7f457a7f92..e0c607847165 100644
--- a/dev-libs/opencryptoki/Manifest
+++ b/dev-libs/opencryptoki/Manifest
@@ -3,3 +3,4 @@ DIST opencryptoki-2.3.3.tar.bz2 694854 SHA256 7ccae6350a7043c2abade1eb1517edb987
DIST opencryptoki-2.4.2.tar.gz 1083876 SHA256 0bfbcf956fec078af12c34cd447c6274a5e7e886335c3b8b81106d20ccefa0d9 SHA512 2f760968cec7f15f7de38f0c74e0444d75d1a247d1efd9fc17a17ac5f2bcc4fd283def49d46baeea0c5adb6e19236993b4e8937f0e32162bcc7dbac8066144b9 WHIRLPOOL d7df0db3450d33c3e28be0031b48f22d89387f12f35ca868f593f82a87abb9eea89f28be43fb4ce3b17dee6e1d226fc08586320fbce4e0bf7d57db871d3cd76c
DIST opencryptoki-2.4.3.tar.gz 1111897 SHA256 3ddc0a0e96957e64e61a960c8a7bfcff0030564ebf4f6848abe0740491fd52bc SHA512 e33d8df344161909c1fc0626880d89e47ac902c5f780cc04af07691fff20c50bdea5bfa0368df39fff84b365342f704638e90b329a3ae12ab5fb5f668c50a164 WHIRLPOOL ab5836f30749e7bb56b1ba882c15098096d7c36e1f9dd65a83a93d9b497231258a54c5a60cf4847fce8267c086a3aea380c33380fcb9d7a20c770f5f922846d7
DIST opencryptoki-v3.3.tgz 937619 SHA256 e1deac5edd571621dc1624e9b7af8d1632d6db6f18815f5ed8824fc78f354609 SHA512 53efbc6009da178473abf17d092249781b1eb465f68c83653bd5e88703b9ad74ce9e0128486dffec65beaf8b8974ea6852d206ec5bf035c7296a40c8f84791ab WHIRLPOOL d939eb97bb7f2b54d510326ac4dba4dc49f9f725fa8900687fd8ebe199ce1c2a797a6e514378995f24ef5b9e904b29434edf962537dc545c2fc2206d180b1d43
+DIST opencryptoki-v3.4.1.tgz 1014416 SHA256 018ea402f3a1b38b203282fb047dfac209d94bf2988f2c29793eca65455452c4 SHA512 98643463102f70226255f17a7c49cc454cce377404155b9624e77e36c9f03fb30c216d1769177666489a539e0886b071103a089c565f8fbf120c2a53239a2dd6 WHIRLPOOL c05b61c220e87af361cf67c5223f5745e305c5039a610bb740d2e729299517363d5d7d03175869ab517519857a526ac0272f1556bd9e1cd9dea84bd500595f7e
diff --git a/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild b/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild
new file mode 100644
index 000000000000..ff61dcb9a7b0
--- /dev/null
+++ b/dev-libs/opencryptoki/opencryptoki-3.4.1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit autotools multilib flag-o-matic user
+
+DESCRIPTION="PKCS#11 provider cryptographic hardware"
+HOMEPAGE="http://sourceforge.net/projects/opencryptoki"
+SRC_URI="mirror://sourceforge/opencryptoki/${PV}/${PN}-v${PV}.tgz"
+
+# Upstream is looking into relicensing it into CPL-1.0 entirely; the CCA
+# token sources are under CPL-1.0 already.
+LICENSE="CPL-0.5"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="tpm? ( app-crypt/trousers )
+ dev-libs/openssl:*"
+DEPEND="${RDEPEND}"
+
+IUSE="+tpm debug"
+
+S="${WORKDIR}/${PN}"
+
+# tests right now basically don't exist; the only available thing would
+# test against an installed copy and would kill a running pcscd, all
+# things that we're not interested to.
+RESTRICT=test
+
+pkg_setup() {
+ enewgroup pkcs11
+}
+
+src_prepare() {
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ # package uses ${localstatedir}/lib as the default path, so if we
+ # leave it to econf, it'll create /var/lib/lib.
+
+ # Since upstream by default seem to enable any possible token, even
+ # when they don't seem to be used, we limit ourselves to the
+ # software emulation token (swtok) and if the user enabled the tpm
+ # USE flag, tpmtok. The rest of the tokens seem to be hardware- or
+ # software-dependent even when they build fine without their
+ # requirements, but until somebody asks for those, I'd rather not
+ # enable them.
+
+ # We don't use --enable-debug because that tinkers with the CFLAGS
+ # and we don't want that. Instead we append -DDEBUG which enables
+ # debug information.
+ use debug && append-flags -DDEBUG
+
+ econf \
+ --localstatedir=/var \
+ --enable-fast-install \
+ --disable-dependency-tracking \
+ --disable-debug \
+ --enable-daemon \
+ --enable-library \
+ --disable-icatok \
+ --enable-swtok \
+ $(use_enable tpm tpmtok) \
+ --disable-ccatok
+}
+
+src_install() {
+ emake install DESTDIR="${ED}"
+
+ # Install libopencryptoki in the standard directory for libraries.
+ mv "${D}"/usr/$(get_libdir)/opencryptoki/libopencryptoki.so* "${D}"/usr/$(get_libdir) || die
+ rm "${D}"/usr/$(get_libdir)/pkcs11/libopencryptoki.so
+ dosym ../libopencryptoki.so /usr/$(get_libdir)/pkcs11/libopencryptoki.so
+
+ # Remove compatibility symlinks as we _never_ required those and
+ # they seem unused even upstream.
+ find "${D}" -name 'PKCS11_*' -delete
+
+ # doesn't use libltdl; only dlopen()-based interfaces
+ find "${D}" -name '*.la' -delete
+
+ # We replace their ld.so and init files (mostly designed for RedHat
+ # as far as I can tell) with our own replacements.
+ rm -rf "${D}"/etc/ld.so.conf.d "${D}"/etc/rc.d
+
+ # make sure that we don't modify the init script if the USE flags
+ # are enabled for the needed services.
+ cp "${FILESDIR}"/pkcsslotd.init.2 "${T}"/pkcsslotd.init
+ use tpm || sed -i -e '/use tcsd/d' "${T}"/pkcsslotd.init
+ newinitd "${T}/pkcsslotd.init" pkcsslotd
+
+ # We create /var dirs at runtime as needed, so don't bother installing
+ # our own.
+ rm -r "${D}"/var/{lib,lock} || die
+
+ dodoc README AUTHORS FAQ TODO doc/openCryptoki-HOWTO.pdf
+}