summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-07-24 11:24:37 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-07-24 11:24:37 +0200
commit7d0d502882a7f43f252cca5be90f0db124c15aa7 (patch)
treebda9b1777851fdea95d21e1016c8b690e4f6807e /dev-libs/wayland-protocols
parentdev-perl/convert-ascii-armour: Remove, gone to dev-perl/Convert-ASCII-Armour (diff)
downloadgentoo-7d0d502882a7f43f252cca5be90f0db124c15aa7.tar.gz
gentoo-7d0d502882a7f43f252cca5be90f0db124c15aa7.tar.bz2
gentoo-7d0d502882a7f43f252cca5be90f0db124c15aa7.zip
dev-libs/wayland-protocols: bump to 1.5, drop multilib support
Bug: https://bugs.gentoo.org/show_bug.cgi?id=587842 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.5.ebuild39
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-9999.ebuild6
3 files changed, 42 insertions, 4 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index c733b30c2b24..1026c883d082 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.3.tar.xz 101684 SHA256 6bcd0633fdf9225ef1c7d2831f542e947f7d79811c79fc37f57b2e5375ded82f SHA512 8e407bce93e595ebb7c6a8c7542d4db81d352821c63f41ac75d27f6d52e81e18e0a9a7d4b18460e446c4201931e42a98c0cd214015f154363099eda5747cd738 WHIRLPOOL 73d5c04cb987d0632fe0cc950cd8bf132f9427bd70a65777027148ada2ede0347b336f7faf6e6455171c1a5b2829835edceca15cbbbaf95b99223976279757a9
DIST wayland-protocols-1.4.tar.xz 102624 SHA256 014a9a23c21ed14f49b1005b3e8efa66d6337d4ceafc97f7b0d6707e7e3df572 SHA512 ffbac79b3be03f7b1c1033923702aadd0bdd2f90dafee946a4a2384eaa9e7f2ab90de6a6497fce374fd3343b133f8dd02683503973a65f947e65b76c47186123 WHIRLPOOL 410923d92e4a962e439f02c5964eb0e61202434bbbf52d68b61549897dcf57040c7b928bad883484802aa3414f63198bba784d644d6c2e8260a78c9247575ac4
+DIST wayland-protocols-1.5.tar.xz 106792 SHA256 7d0b426ccaeafc084fc579bb2a139f8ad4ea3492d54b7b0210d124c61fbeb2bf SHA512 8a3305151cbf7d69e4c36dc5d132a607af4944ed2737f0c50fbc540faf60fb6e742402883f55377a3215427afa92a95fb693398419335c4de0ac9bb9bfb9f607 WHIRLPOOL b883327d1e5f7e71f32ea3052d2532a05cbafc0081ab0703c0aeeee2b4f3e9713d1c0adc1cf7f01341428b4d711a9ccd60184d994fbf16bbfc2342f2c84f4eef
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.5.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.5.ebuild
new file mode 100644
index 000000000000..f26f25bad3d7
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+ inherit autotools-utils git-r3
+fi
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-utils_src_test
+}
diff --git a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
index 9beb33b1eac8..f26f25bad3d7 100644
--- a/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
+++ b/dev-libs/wayland-protocols/wayland-protocols-9999.ebuild
@@ -6,13 +6,11 @@ EAPI=5
if [[ ${PV} = 9999* ]]; then
EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
- GIT_ECLASS="git-r3"
EXPERIMENTAL="true"
AUTOTOOLS_AUTORECONF=1
+ inherit autotools-utils git-r3
fi
-inherit autotools-multilib $GIT_ECLASS
-
DESCRIPTION="Wayland protocol files"
HOMEPAGE="https://wayland.freedesktop.org/"
@@ -37,5 +35,5 @@ src_test() {
mkdir "${XDG_RUNTIME_DIR}" || die
chmod 0700 "${XDG_RUNTIME_DIR}" || die
- autotools-multilib_src_test
+ autotools-utils_src_test
}