summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-07-16 11:20:35 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-07-16 11:21:03 +0200
commitd6461c886d235eab0a2c344150cdbd0ee4fbb9f4 (patch)
tree9a0af9a2f04bff27b747ba59f3cc3836908d8ad2 /dev-libs/wayland-protocols
parentkde-misc/krename-4.0.9_p20170610-r0: add amd64 keyword (diff)
downloadgentoo-d6461c886d235eab0a2c344150cdbd0ee4fbb9f4.tar.gz
gentoo-d6461c886d235eab0a2c344150cdbd0ee4fbb9f4.tar.bz2
gentoo-d6461c886d235eab0a2c344150cdbd0ee4fbb9f4.zip
dev-libs/wayland-protocols: Version bump to 1.9
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.9.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 36e30c1484ec..777857de27cb 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.7.tar.xz 113220 SHA256 635f2a937d318f1fecb97b54074ca211486e38af943868dd0fa82ea38d091c1f SHA512 291a3226cc538de3b81bdffa5de513b305a946bfc3481e21c254fcc6a023e0cf2ff1869509c7ae193da02460f1d4a3c5cd5f1ca13b2550886acffcc636fb30d2 WHIRLPOOL 6528e73461455278f2086fc953d251042f870360ab854f388658eb353f3d0affcc6aa369d912a3edc9040a026468a3a0f63b42cbc2a27a0902e9ab94ae2a7bfc
DIST wayland-protocols-1.8.tar.xz 112124 SHA256 e3fa5f2812cfec3c1c2573bd34adfe37d4d8950dba572d9ec6c52adcc5fe4b9a SHA512 8d9bbd4eb52c0b727c75f0379e53e29a197ce21f5a0a10a6351c053e26a635b53dcb418fa44f0fa5e0484d1457681a7f69afd3c98f2095be16ae1b0d0aeb0c50 WHIRLPOOL 4974b1c88ab32a3ec334c15c00e3f3dcf09ffeba9d909140d980d037e4edb21cd906699afd83577cc7505f399b2b10e75ca6df157a97e313b1d182cf5a673c5c
+DIST wayland-protocols-1.9.tar.xz 116152 SHA256 666b72de30ca3b70c2b54ccc9e8114cb520e76db224c816b5e23501099174f75 SHA512 16154520dd355ba9d459baf942945c6b7d267ab4463a31eba76f5d300569ffa993641f65d3e2cde89d735767a3bf743382449f58c5f42521dbdc7db1b1d0dc0d WHIRLPOOL 25102072f7b3e7be0a6a860c4992ff301d0afda4d91867daf5e0e848dbb3d986c0f1ba9162210b00acc12ff9af2aa6c19c19718b98c289433c24df18cec780a9
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.9.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.9.ebuild
new file mode 100644
index 000000000000..3c94786ff4ba
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/wayland/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-utils ${GIT_ECLASS}
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="https://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/wayland"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-utils_src_test
+}