summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/xplc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/xplc')
-rw-r--r--dev-libs/xplc/Manifest1
-rw-r--r--dev-libs/xplc/files/xplc-0.3.13-as-needed.patch22
-rw-r--r--dev-libs/xplc/metadata.xml9
-rw-r--r--dev-libs/xplc/xplc-0.3.13-r1.ebuild42
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-libs/xplc/Manifest b/dev-libs/xplc/Manifest
new file mode 100644
index 000000000000..f93d2f6946ab
--- /dev/null
+++ b/dev-libs/xplc/Manifest
@@ -0,0 +1 @@
+DIST xplc-0.3.13.tar.gz 175431 SHA256 158a0f44a2eb055522377c275bbd0e7412dd3b8a9b75ec344c0457b3a1a29cbb SHA512 6969ed16c282589ddc285678e1c02016810f83c4c0fea373d8b7a72c97474e6cc21ca3f8f7a7a6aae814037dfae51c3a41bd39f13a67445552b6a7c1b698195d WHIRLPOOL a4f40cb8d25b1af645d47c53a5cedbb6780b79db427fd2212f997eeaf224ae7a888063efd6b15fdd0b5b336957db81de45dbbcc50cb931302f3e0563fb966d7e
diff --git a/dev-libs/xplc/files/xplc-0.3.13-as-needed.patch b/dev-libs/xplc/files/xplc-0.3.13-as-needed.patch
new file mode 100644
index 000000000000..3e002db2ad00
--- /dev/null
+++ b/dev-libs/xplc/files/xplc-0.3.13-as-needed.patch
@@ -0,0 +1,22 @@
+--- config/rules.mk.orig 2006-05-06 19:28:46.000000000 +0200
++++ config/rules.mk 2006-05-06 19:28:53.000000000 +0200
+@@ -44,7 +44,7 @@
+ $(RANLIB) $@
+
+ %.so:
+- $(LINK.cc) $(SHARED) $^ -o $@
++ $(LINK.cc) $(SHARED) $^ $(LDLIBS) -o $@
+
+ %.dll:
+ $(LINK.cc) $(SHARED) $^ -o $@
+--- xplc/vars.mk.orig 2006-05-06 19:32:06.000000000 +0200
++++ xplc/vars.mk 2006-05-06 19:32:12.000000000 +0200
+@@ -32,7 +32,7 @@
+
+ ifneq ("$(enable_loader)", "no")
+ ifneq ("$(with_dlopen)", "no")
+-libxplc.so: LDFLAGS+=$(with_dlopen)
++libxplc.so: LDLIBS+=$(with_dlopen)
+ endif
+ endif
+
diff --git a/dev-libs/xplc/metadata.xml b/dev-libs/xplc/metadata.xml
new file mode 100644
index 000000000000..d151eb9a26d0
--- /dev/null
+++ b/dev-libs/xplc/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>cpp</herd>
+ <longdescription>cross platform lightweight components library for C++</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xplc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-libs/xplc/xplc-0.3.13-r1.ebuild b/dev-libs/xplc/xplc-0.3.13-r1.ebuild
new file mode 100644
index 000000000000..ae671571b0de
--- /dev/null
+++ b/dev-libs/xplc/xplc-0.3.13-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="cross platform lightweight components library for C++"
+HOMEPAGE="http://xplc.sourceforge.net"
+SRC_URI="mirror://sourceforge/xplc/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc sparc x86"
+IUSE=""
+
+DEPEND="virtual/pkgconfig"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ #solve conflict with uuidgen utility installed by sys-fs/e2fsprogs (#116699)
+ sed -i -e "s/uuidgen/xplc-uuidgen/g" -e "s/uuidcdef/xplc-uuidcdef/g" \
+ uuid/{rules.mk,vars.mk} config/rules.mk \
+ uuid/bin/*.1 include/xplc/*.h && \
+ mv uuid/bin/uuidgen.1 uuid/bin/xplc-uuidgen.1 &&
+ mv uuid/bin/uuidgen.c uuid/bin/xplc-uuidgen.c ||
+ die "uuidgen rename failed"
+}
+
+src_test() {
+ make tests || die "at least one test has failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dosym /usr/lib/pkgconfig/${P}.pc /usr/lib/pkgconfig/${PN}.pc
+ dodoc LICENSE README NEWS CREDITS
+}