summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-02-24 22:34:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-02-24 23:39:46 +0100
commit193ee5c1fbb0ed6ee6b3fe85b4c251a2cea3846a (patch)
tree7f57058d977b909d8a8705df2a1ef570366973ba /dev-libs
parentprofiles: Mask kde-apps/kdepim-apps-libs for removal (diff)
downloadgentoo-193ee5c1fbb0ed6ee6b3fe85b4c251a2cea3846a.tar.gz
gentoo-193ee5c1fbb0ed6ee6b3fe85b4c251a2cea3846a.tar.bz2
gentoo-193ee5c1fbb0ed6ee6b3fe85b4c251a2cea3846a.zip
dev-libs/dbus-c++: Drop 0.9.0-r3, EAPI5--
Bug: https://bugs.gentoo.org/766791 Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/dbus-c++/dbus-c++-0.9.0-r3.ebuild64
1 files changed, 0 insertions, 64 deletions
diff --git a/dev-libs/dbus-c++/dbus-c++-0.9.0-r3.ebuild b/dev-libs/dbus-c++/dbus-c++-0.9.0-r3.ebuild
deleted file mode 100644
index afa3caaaab8a..000000000000
--- a/dev-libs/dbus-c++/dbus-c++-0.9.0-r3.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-AUTOTOOLS_PRUNE_LIBTOOL_FILES="modules"
-
-inherit autotools-multilib eutils
-
-DESCRIPTION="Provides a C++ API for D-BUS"
-HOMEPAGE="https://sourceforge.net/projects/dbus-cplusplus/ https://sourceforge.net/apps/mediawiki/dbus-cplusplus/index.php?title=Main_Page"
-SRC_URI="mirror://sourceforge/dbus-cplusplus/lib${P}.tar.gz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86"
-IUSE="doc ecore glib static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="sys-apps/dbus[${MULTILIB_USEDEP}]
- ecore? ( dev-libs/efl )
- glib? ( dev-libs/glib:2[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- dev-util/cppunit[${MULTILIB_USEDEP}]
- virtual/pkgconfig"
-
-S=${WORKDIR}/lib${P}
-
-PATCHES=(
- "${FILESDIR}"/${P}-gcc-4.7.patch #424707
- "${FILESDIR}"/${PN}-gcc7.patch #622790
-)
-
-multilib_src_configure() {
- # not just using autotools-multilib_src_configure because of multilib_native... logic
-
- # TODO : add ecore multilib support if/when it is multilibified
- ECONF_SOURCE="${S}" econf \
- --disable-examples \
- $(multilib_native_use_enable doc doxygen-docs) \
- $(multilib_native_use_enable ecore) \
- $(use_enable glib) \
- $(use_enable static-libs static) \
- $(use_enable test tests) \
- PTHREAD_LIBS=-lpthread
- # ACX_PTHREAD sets PTHREAD_CFLAGS but not PTHREAD_LIBS for some reason...
-
- if multilib_is_native_abi; then
- # docs don't like out-of-source builds
- local d
- for d in img html; do
- ln -s "${S}"/doc/${d} "${BUILD_DIR}"/doc/${d} || die
- done
- fi
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- if use doc; then
- dohtml -r "${S}"/doc/html/*
- fi
-}