summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-12-29 10:43:01 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-12-29 10:43:26 +0000
commit66cdca4a0b121ae77b2530b080e414f96569206a (patch)
tree00410c2666a1b1dedcdbcdab307cfd231584dd55 /dev-libs
parentdev-python/libzilla: clean up old. (diff)
downloadgentoo-66cdca4a0b121ae77b2530b080e414f96569206a.tar.gz
gentoo-66cdca4a0b121ae77b2530b080e414f96569206a.tar.bz2
gentoo-66cdca4a0b121ae77b2530b080e414f96569206a.zip
dev-libs/mpc: remove eautoreconf call from ebuild, bug #642300
As mpc is one of bootstrap libraries it's highly undesirable to depend on autotools. Early autotools requirement breaks prefix bootstrap for example. See https://bugs.gentoo.org/642300 The change updates patch to modify both configure.ac and configure. Bug: https://bugs.gentoo.org/642576 Closes: https://bugs.gentoo.org/642300 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mpc/files/mpc-1.0.3-mpfr-4.0.0.patch44
-rw-r--r--dev-libs/mpc/mpc-1.0.3-r1.ebuild3
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-libs/mpc/files/mpc-1.0.3-mpfr-4.0.0.patch b/dev-libs/mpc/files/mpc-1.0.3-mpfr-4.0.0.patch
index 7f9f7e2b9743..72d6f2217caf 100644
--- a/dev-libs/mpc/files/mpc-1.0.3-mpfr-4.0.0.patch
+++ b/dev-libs/mpc/files/mpc-1.0.3-mpfr-4.0.0.patch
@@ -80,6 +80,50 @@ index 3c9c0a7..8c4afe4 100644
mpc_set (z, rop, MPC_RNDNN);
if (overlap)
+--- a/configure
++++ b/configure
+@@ -13835,6 +13835,41 @@ else
+ $as_echo "no" >&6; }
+ as_fn_error $? "libmpfr not found or uses a different ABI (including static vs shared)." "$LINENO" 5
+
++fi
++rm -f core conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for mpfr_fmma" >&5
++$as_echo_n "checking for mpfr_fmma... " >&6; }
++LIBS="-lmpfr $LIBS"
++cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h. */
++#include "mpfr.h"
++int
++main ()
++{
++mpfr_t x; mpfr_fmma (x, x, x, x, x, 0);
++
++ ;
++ return 0;
++}
++_ACEOF
++if ac_fn_c_try_link "$LINENO"; then :
++
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++
++$as_echo "#define HAVE_MPFR_FMMA 1" >>confdefs.h
++
++
++else
++
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
++$as_echo "no" >&6; }
++
++$as_echo "#define HAVE_MPFR_FMMA 0" >>confdefs.h
++
++
+ fi
+ rm -f core conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
--
2.15.1
diff --git a/dev-libs/mpc/mpc-1.0.3-r1.ebuild b/dev-libs/mpc/mpc-1.0.3-r1.ebuild
index c35082341337..43c7e147e0d3 100644
--- a/dev-libs/mpc/mpc-1.0.3-r1.ebuild
+++ b/dev-libs/mpc/mpc-1.0.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools eutils libtool multilib-minimal
+inherit eutils libtool multilib-minimal
DESCRIPTION="A library for multiprecision complex arithmetic with exact rounding"
HOMEPAGE="http://mpc.multiprecision.org/"
@@ -26,7 +26,6 @@ PATCHES=(
src_prepare() {
default
- eautoreconf
elibtoolize #347317
}