summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:22:00 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:40 +0100
commitd407343527a78d412a81f4eab87b3304a81d4c28 (patch)
treede62f24ccf1a88020122cdf0ebbd2d2ede70721b /dev-lua
parentdev-lua/lua-utf8: drop 0.1.3-r100 (diff)
downloadgentoo-d407343527a78d412a81f4eab87b3304a81d4c28.tar.gz
gentoo-d407343527a78d412a81f4eab87b3304a81d4c28.tar.bz2
gentoo-d407343527a78d412a81f4eab87b3304a81d4c28.zip
dev-lua/lua-zlib: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/lua-zlib/lua-zlib-1.2-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lua/lua-zlib/lua-zlib-1.2-r1.ebuild b/dev-lua/lua-zlib/lua-zlib-1.2-r1.ebuild
new file mode 100644
index 000000000000..fc772503f8ab
--- /dev/null
+++ b/dev-lua/lua-zlib/lua-zlib-1.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit cmake lua
+
+DESCRIPTION="Simple streaming interface to zlib for Lua"
+HOMEPAGE="https://github.com/brimworks/lua-zlib"
+SRC_URI="https://github.com/brimworks/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+RDEPEND="
+ sys-libs/zlib
+ ${LUA_DEPS}
+
+"
+DEPEND="${RDEPEND}"
+
+lua_src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_CMOD="$(lua_get_cmod_dir)"
+ -DUSE_LUA_VERSION="$(lua_get_version)"
+ )
+
+ if [[ ${ELUA} == luajit ]]; then
+ mycmakeargs+=( -DUSE_LUAJIT="ON" )
+ fi
+
+ cmake_src_configure
+}
+
+src_configure() {
+ lua_foreach_impl lua_src_configure
+}
+
+src_compile() {
+ lua_foreach_impl cmake_src_compile
+}
+
+src_install() {
+ lua_foreach_impl cmake_src_install
+}