summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-06 15:14:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-06 15:21:10 +0200
commit899b27034ad77bf7339a2e3c1cd66e9cdf791502 (patch)
tree48e9ba0d835f7c006d6561b39659142f8222bb9c /dev-ml/dns/dns-1.0.0.ebuild
parentdev-perl/Date-Pcalc: Fix test failures re bug #615580 (diff)
downloadgentoo-899b27034ad77bf7339a2e3c1cd66e9cdf791502.tar.gz
gentoo-899b27034ad77bf7339a2e3c1cd66e9cdf791502.tar.bz2
gentoo-899b27034ad77bf7339a2e3c1cd66e9cdf791502.zip
dev-ml/dns: move from dev-ml/ocaml-dns to match opam name
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml/dns/dns-1.0.0.ebuild')
-rw-r--r--dev-ml/dns/dns-1.0.0.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-ml/dns/dns-1.0.0.ebuild b/dev-ml/dns/dns-1.0.0.ebuild
new file mode 100644
index 000000000000..85d9d78a23c1
--- /dev/null
+++ b/dev-ml/dns/dns-1.0.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ocaml-${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-3.0.2:=[ppx]
+ dev-ml/ocaml-hashcons:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ dev-ml/result:=
+ !dev-ml/odns
+"
+DEPEND="
+ dev-ml/jbuilder
+ dev-ml/opam
+ ${RDEPEND}
+"
+
+# Do not work
+RESTRICT="test"
+
+S="${WORKDIR}/ocaml-${P}"
+
+src_compile() {
+ jbuilder build @install -p dns || die
+}
+
+src_test() {
+ jbuilder runtest -p dns || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ dns.install || die
+}