summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-13 10:17:31 +0000
committerSam James <sam@gentoo.org>2021-03-13 15:23:10 +0000
commit5e3a8cb29cfeadaadc6a42ea19ace78a66abf08c (patch)
treebd55478af36e4f36176af972d240260887422ac9 /dev-ml/ocamlgraph
parentdev-ml/ocamlgraph: drop 1.8.7-r1, 2.0.0 (diff)
downloadgentoo-5e3a8cb29cfeadaadc6a42ea19ace78a66abf08c.tar.gz
gentoo-5e3a8cb29cfeadaadc6a42ea19ace78a66abf08c.tar.bz2
gentoo-5e3a8cb29cfeadaadc6a42ea19ace78a66abf08c.zip
dev-ml/ocamlgraph: port 1.8.8 to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlgraph')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.8-r2.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.8-r2.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.8-r2.ebuild
new file mode 100644
index 000000000000..0f74d2731a27
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.8.8-r2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
+IUSE="doc examples gtk +ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:2=[gnomecanvas,ocamlopt?] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake opt
+
+ if use doc; then
+ emake doc
+ fi
+
+ if use gtk; then
+ emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ use ocamlopt || export WANT_OCAMLOPT=no
+ use gtk && export WANT_GTK=yes
+ emake install-findlib
+
+ if use gtk ; then
+ local ext=byte
+ use ocamlopt && ext=opt
+ newbin dgraph/dgraph.${ext} ${PN}-dgraph
+ newbin editor/editor.${ext} ${PN}-editor
+ newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
+ fi
+
+ dodoc README.adoc CREDITS FAQ CHANGES
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ if use doc; then
+ docinto html
+ dodoc doc/*
+ fi
+}