summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 16:48:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:45 +0200
commit9be1c924306a3e7a7cb4a50d329655921bb31320 (patch)
treea9a153965729139a2d89d428336e5495e01dc3cc /dev-ml/ppx_type_conv
parentdev-ml/ppx_metaquot: Initial import. (diff)
downloadgentoo-9be1c924306a3e7a7cb4a50d329655921bb31320.tar.gz
gentoo-9be1c924306a3e7a7cb4a50d329655921bb31320.tar.bz2
gentoo-9be1c924306a3e7a7cb4a50d329655921bb31320.zip
dev-ml/ppx_type_conv: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_type_conv')
-rw-r--r--dev-ml/ppx_type_conv/Manifest2
-rw-r--r--dev-ml/ppx_type_conv/ppx_type_conv-0.9.0.ebuild32
-rw-r--r--dev-ml/ppx_type_conv/ppx_type_conv-113.33.02.ebuild46
3 files changed, 33 insertions, 47 deletions
diff --git a/dev-ml/ppx_type_conv/Manifest b/dev-ml/ppx_type_conv/Manifest
index 3ffeb95738d2..52ac05d7af5b 100644
--- a/dev-ml/ppx_type_conv/Manifest
+++ b/dev-ml/ppx_type_conv/Manifest
@@ -1 +1 @@
-DIST ppx_type_conv-113.33.02+4.03.tar.gz 60598 SHA256 a211cc73cc3f31b6765b022bb851d762d9f6fa4c6b64666242923d5102d4f078 SHA512 305a46b9bf6ed6b082f5b794d180b9b194ed5f183d75e31fe49a392fa06c8cdfce1825987f9da0080bf83c49bf10dfd54837b22d73e50bc4eea8707bb64b7303 WHIRLPOOL 760ef375523410a8a1333bb5274a55efa8b27cd412a185fd65d6128a5f9ce5cb97d9d3703165cddf71b9f6c0d7c6a57baed6539bc22b8d689d19a8b1f54231d6
+DIST ppx_type_conv-0.9.0.tar.gz 14651 SHA256 895293faaebda30a514458164d97e598577f521e440e1f95628f445abdaf3d26 SHA512 71af29d7e882652a5e101e1fc3610adb4faaba30068161b4b391e3ce7419af7feffd289070c1707cc961c593eda7b7f325609e8c98543c1168400cfafea31472 WHIRLPOOL b8aa67ba9e6258774f971a51d0c06f85d7f9fb270dad8ac8b3bc3f7a1f45b9dc2a33f83a01175a7cffb8da06be959d8bd3109fd20910ba3937c88cf9905c859f
diff --git a/dev-ml/ppx_type_conv/ppx_type_conv-0.9.0.ebuild b/dev-ml/ppx_type_conv/ppx_type_conv-0.9.0.ebuild
new file mode 100644
index 000000000000..b8868855e53d
--- /dev/null
+++ b/dev-ml/ppx_type_conv/ppx_type_conv-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_type_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_core:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_deriving:=
+"
+
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/ppx_type_conv/ppx_type_conv-113.33.02.ebuild b/dev-ml/ppx_type_conv/ppx_type_conv-113.33.02.ebuild
deleted file mode 100644
index 00662f56a692..000000000000
--- a/dev-ml/ppx_type_conv/ppx_type_conv-113.33.02.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit oasis eutils
-
-DESCRIPTION="Support Library for type-driven code generators"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}+4.03.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-ml/ppx_tools:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_deriving:=
- dev-ml/ppx_core:=
- dev-ml/ppx_optcomp:=
- >=dev-lang/ocaml-4.03:=
-"
-
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam"
-
-S=${WORKDIR}/${P}+4.03
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
-}