summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ml/xml-light/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ml/xml-light/files')
-rw-r--r--dev-ml/xml-light/files/01_installopt.dpatch24
-rw-r--r--dev-ml/xml-light/files/02_cmi_depends.dpatch18
-rw-r--r--dev-ml/xml-light/files/03_cflags.dpatch51
-rw-r--r--dev-ml/xml-light/files/04_dtd_trace.dpatch26
4 files changed, 119 insertions, 0 deletions
diff --git a/dev-ml/xml-light/files/01_installopt.dpatch b/dev-ml/xml-light/files/01_installopt.dpatch
new file mode 100644
index 000000000000..1dfb50c9e271
--- /dev/null
+++ b/dev-ml/xml-light/files/01_installopt.dpatch
@@ -0,0 +1,24 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 01_installopt.dpatch by Sylvain Le Gall <gildor@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad xml-light-2.2~/Makefile xml-light-2.2/Makefile
+--- xml-light-2.2~/Makefile 2005-10-11 23:26:41.000000000 +0200
++++ xml-light-2.2/Makefile 2005-10-11 23:28:00.000000000 +0200
+@@ -11,8 +11,11 @@
+
+ opt: xml-light.cmxa test_opt.exe
+
+-install: all opt
+- cp xml-light.cmxa xml-light.a xml-light.cma xml.mli xmlParser.mli dtd.mli xml.cmi xmlParser.cmi dtd.cmi xml.cmx dtd.cmx xmlParser.cmx $(INSTALLDIR)
++install: all
++ cp xml-light.cma xml.mli xmlParser.mli dtd.mli xml.cmi xmlParser.cmi dtd.cmi $(INSTALLDIR)
++
++installopt: opt all
++ cp xml-light.a xml-light.cmxa xml.cmx dtd.cmx xmlParser.cmx $(INSTALLDIR)
+
+ doc:
+ mkdir doc
diff --git a/dev-ml/xml-light/files/02_cmi_depends.dpatch b/dev-ml/xml-light/files/02_cmi_depends.dpatch
new file mode 100644
index 000000000000..1fcf17048407
--- /dev/null
+++ b/dev-ml/xml-light/files/02_cmi_depends.dpatch
@@ -0,0 +1,18 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 02_cmi_depends.dpatch by Sylvain Le Gall <gildor@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad xml-light-2.2~/Makefile xml-light-2.2/Makefile
+--- xml-light-2.2~/Makefile 2006-01-03 17:34:23.000000000 +0100
++++ xml-light-2.2/Makefile 2006-01-03 17:35:04.000000000 +0100
+@@ -82,6 +82,6 @@
+ .mll.ml:
+ ocamllex $<
+
+-.mly.ml:
++%.mli %.ml: %.mly
+ ocamlyacc $<
+
diff --git a/dev-ml/xml-light/files/03_cflags.dpatch b/dev-ml/xml-light/files/03_cflags.dpatch
new file mode 100644
index 000000000000..5dfbffe5da1f
--- /dev/null
+++ b/dev-ml/xml-light/files/03_cflags.dpatch
@@ -0,0 +1,51 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 03_cflags.dpatch by Sylvain Le Gall <gildor@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad xml-light-2.2~/Makefile xml-light-2.2/Makefile
+--- xml-light-2.2~/Makefile 2006-10-26 00:22:41.000000000 +0200
++++ xml-light-2.2/Makefile 2006-10-26 00:24:45.000000000 +0200
+@@ -3,8 +3,8 @@
+ .SUFFIXES : .ml .mli .cmo .cmx .cmi .mll .mly
+
+ INSTALLDIR=`ocamlc -where`
+-CFLAGS=
+-LFLAGS= -a
++XML_LIGHT_OCAML_CFLAGS= $(OCAML_CFLAGS)
++XML_LIGHT_OCAML_LFLAGS= $(OCAML_LFLAGS) -a
+ LIBS=
+
+ all: xml-light.cma test.exe doc
+@@ -28,10 +28,10 @@
+ ocamlopt xml-light.cmxa test.ml -o test_opt.exe
+
+ xml-light.cma: xml_parser.cmo xml_lexer.cmo dtd.cmo xmlParser.cmo xml.cmo
+- ocamlc -o xml-light.cma $(LFLAGS) $(LIBS) xml_parser.cmo xml_lexer.cmo dtd.cmo xmlParser.cmo xml.cmo
++ ocamlc -o xml-light.cma $(XML_LIGHT_OCAML_LFLAGS) $(LIBS) xml_parser.cmo xml_lexer.cmo dtd.cmo xmlParser.cmo xml.cmo
+
+ xml-light.cmxa: xml_parser.cmx xml_lexer.cmx dtd.cmx xmlParser.cmx xml.cmx
+- ocamlopt -o xml-light.cmxa $(LFLAGS) $(LIBS) xml_parser.cmx xml_lexer.cmx dtd.cmx xmlParser.cmx xml.cmx
++ ocamlopt -o xml-light.cmxa $(XML_LIGHT_OCAML_LFLAGS) $(LIBS) xml_parser.cmx xml_lexer.cmx dtd.cmx xmlParser.cmx xml.cmx
+
+ dtd.cmo: xml.cmi xml_lexer.cmi dtd.cmi
+
+@@ -71,13 +71,13 @@
+
+ # SUFFIXES
+ .ml.cmo:
+- ocamlc $(CFLAGS) -c $<
++ ocamlc $(XML_LIGHT_OCAML_CFLAGS) -c $<
+
+ .ml.cmx:
+- ocamlopt $(CFLAGS) -c $<
++ ocamlopt $(XML_LIGHT_OCAML_CFLAGS) -c $<
+
+ .mli.cmi:
+- ocamlc $(CFLAGS) $<
++ ocamlc $(XML_LIGHT_OCAML_CFLAGS) $<
+
+ .mll.ml:
+ ocamllex $<
diff --git a/dev-ml/xml-light/files/04_dtd_trace.dpatch b/dev-ml/xml-light/files/04_dtd_trace.dpatch
new file mode 100644
index 000000000000..9dbea4bdf0c8
--- /dev/null
+++ b/dev-ml/xml-light/files/04_dtd_trace.dpatch
@@ -0,0 +1,26 @@
+#! /bin/sh /usr/share/dpatch/dpatch-run
+## 04_dtd_trace.dpatch by Sylvain Le Gall <gildor@debian.org>
+##
+## All lines beginning with `## DP:' are a description of the patch.
+## DP: No description.
+
+@DPATCH@
+diff -urNad xml-light-2.2~/dtd.ml xml-light-2.2/dtd.ml
+--- xml-light-2.2~/dtd.ml 2005-02-18 10:01:54.000000000 +0100
++++ xml-light-2.2/dtd.ml 2006-10-26 23:22:25.000000000 +0200
+@@ -267,7 +267,7 @@
+ exception TmpResult of dtd_result
+
+ let prove_child dtd tag =
+- trace dtd tag;
++ (*trace dtd tag;*)
+ match dtd.current with
+ | DTDEmpty -> raise (Prove_error EmptyExpected)
+ | DTDAny -> ()
+@@ -505,4 +505,4 @@
+ sprintf "<!ELEMENT %s %s>" tag (etype_to_string etype)
+
+ ;;
+-to_string_ref := to_string
+\ No newline at end of file
++to_string_ref := to_string