summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-17 09:01:54 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-17 10:46:56 +0100
commit1c65670e1aca599cdbe751b14bb7f94e7f9c968c (patch)
tree9cb4b2e421ca526a2ddbb33ea8c87776dde960e6 /dev-ml
parentapp-crypt/gpgme: cleanup (diff)
downloadgentoo-1c65670e1aca599cdbe751b14bb7f94e7f9c968c.tar.gz
gentoo-1c65670e1aca599cdbe751b14bb7f94e7f9c968c.tar.bz2
gentoo-1c65670e1aca599cdbe751b14bb7f94e7f9c968c.zip
dev-ml/topkg: Bump to 0.9.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/topkg/Manifest1
-rw-r--r--dev-ml/topkg/topkg-0.9.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/topkg/Manifest b/dev-ml/topkg/Manifest
index e6d16748860d..ac7807be0d4b 100644
--- a/dev-ml/topkg/Manifest
+++ b/dev-ml/topkg/Manifest
@@ -1 +1,2 @@
DIST topkg-0.8.1.tar.gz 118529 SHA256 368bf199fe0e92d248057bcb635a1aec081607cc2c64699fa21885e4ea00325c SHA512 d427b9c9e05541b3574a9818efe435c2fade22b0789a4aee3032068b5cdf606634e218e848ef220ab2174272e71a3490e8d7a4acc564f4cc987ed703194b2609 WHIRLPOOL e227990bc32eca743bd3cc74ea6f2af8ded8a10286f5e24579d84c2d3745c7d001b0a72316e317b2f65fa88cafa3c1110fd5ea39c8979f22f7a54560545696a7
+DIST topkg-0.9.0.tar.gz 120352 SHA256 1f9a718d49151ac4e914404e78865cc74e361d7befea2167fb8daa78a68fba11 SHA512 823fe1abb344d7800e09411c952bd276ecea97b5d9c124d986e26b9128d03b3ad023a38560198e476ef8f949ecb456078e332bda94075e9b746e43d3059a8fdb WHIRLPOOL 03be4f92aa654e46ffe46e49f59bac3fabb96982d512811fe1232fa067829ef09ba585bcf26bebba07aef1394497fd2551102dc97ba1f078b9b5e7d685c410be
diff --git a/dev-ml/topkg/topkg-0.9.0.ebuild b/dev-ml/topkg/topkg-0.9.0.ebuild
new file mode 100644
index 000000000000..9cc38a3b5996
--- /dev/null
+++ b/dev-ml/topkg/topkg-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="The transitory OCaml software packager"
+HOMEPAGE="http://erratique.ch/software/topkg https://github.com/dbuenzli/topkg"
+SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+RDEPEND="dev-ml/result:=
+ dev-lang/ocaml:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --pkg-name ${PN} || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs="$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ dodoc CHANGES.md DEVEL.md README.md
+}