summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-04 08:58:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-04 08:58:42 +0200
commit71182f821273a894cb9c960a72b33658bc7dd56d (patch)
tree0cc02823cfe77b7e72a5d9bc67708d06092b83a0 /dev-ml
parentdev-ruby/actionpack: add rails 4.2.9 (diff)
downloadgentoo-71182f821273a894cb9c960a72b33658bc7dd56d.tar.gz
gentoo-71182f821273a894cb9c960a72b33658bc7dd56d.tar.bz2
gentoo-71182f821273a894cb9c960a72b33658bc7dd56d.zip
dev-ml/ocaml-cstruct: build only enabled targets, should fix bug #623742
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild16
1 files changed, 16 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild
index 388db7e25424..39b192f16a3c 100644
--- a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.2.ebuild
@@ -38,6 +38,22 @@ DEPEND="
${RDEPEND}
"
+get_targets() {
+ local tgt="cstruct,cstruct-unix"
+ use lwt && tgt+=",cstruct-lwt"
+ use async && tgt+=",cstruct-async"
+ use ppx && tgt+=",ppx_cstruct"
+ echo "${tgt}"
+}
+
+src_compile() {
+ jbuilder build -p $(get_targets) || die
+}
+
+src_test() {
+ jbuilder runtest -p $(get_targets) || die
+}
+
oinstall() {
opam-installer -i \
--prefix="${ED}/usr" \