summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/CGI-Emulate-PSGI
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/CGI-Emulate-PSGI')
-rw-r--r--dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.200.0.ebuild29
-rw-r--r--dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.210.0.ebuild29
-rw-r--r--dev-perl/CGI-Emulate-PSGI/Manifest2
-rw-r--r--dev-perl/CGI-Emulate-PSGI/metadata.xml10
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.200.0.ebuild b/dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.200.0.ebuild
new file mode 100644
index 000000000000..5ad0f5daed64
--- /dev/null
+++ b/dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.200.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIYAGAWA
+MODULE_VERSION=0.20
+inherit perl-module
+
+DESCRIPTION="PSGI adapter for CGI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/CGI-3.630.0
+ dev-perl/HTTP-Message
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-Requires-0.80.0
+ )
+"
+
+SRC_TEST=do
diff --git a/dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.210.0.ebuild b/dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.210.0.ebuild
new file mode 100644
index 000000000000..93a29d55c106
--- /dev/null
+++ b/dev-perl/CGI-Emulate-PSGI/CGI-Emulate-PSGI-0.210.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MIYAGAWA
+MODULE_VERSION=0.21
+inherit perl-module
+
+DESCRIPTION="PSGI adapter for CGI"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/CGI-3.630.0
+ dev-perl/HTTP-Message
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ >=dev-perl/Test-Requires-0.80.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/CGI-Emulate-PSGI/Manifest b/dev-perl/CGI-Emulate-PSGI/Manifest
new file mode 100644
index 000000000000..61b4edc64c20
--- /dev/null
+++ b/dev-perl/CGI-Emulate-PSGI/Manifest
@@ -0,0 +1,2 @@
+DIST CGI-Emulate-PSGI-0.20.tar.gz 14321 SHA256 3865106b22b88a0fa55821c84625acdbfa4758b1d341c6abe62613d363e2d3c2 SHA512 34f2d5e0a93e3b63a9409274d5a93f6718314e55a80c87c707ad846d7542fe64c7660786801e005402051871b9a1d9dc311d78854e5e7daddc33a9a276b031e3 WHIRLPOOL 911dd7e30219b5e1dd05f0e47f44ebc01df3d2053df45193b9498fada6438114b113123c356a6d9922597a426e3025ae4e6e99371aa710d233006b4c1f103ebc
+DIST CGI-Emulate-PSGI-0.21.tar.gz 14429 SHA256 06b8f1864101de69b2264ad3c3a2b15333e428cf9f5d17a777cfc61f8c64093f SHA512 598355fe77f3fa2b71d713809fd73909bbb74b317dc34fb0febed851fc25cfb56ac622d070551f8bdb582ba0ab0bbd69b0e9185d059d5351f02faffe75ea2be8 WHIRLPOOL b4f64077d2b5c967666e7e1a54a7e5127bebd02779ad15c2f71d9e585d9cfbbbb3f89ec9defea17d377c6fabc1a20bd82ee9393f3409e87378bea17f7ecf47f4
diff --git a/dev-perl/CGI-Emulate-PSGI/metadata.xml b/dev-perl/CGI-Emulate-PSGI/metadata.xml
new file mode 100644
index 000000000000..2b4f34faf080
--- /dev/null
+++ b/dev-perl/CGI-Emulate-PSGI/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">CGI-Emulate-PSGI</remote-id>
+ <remote-id type="cpan-module">CGI::Emulate::PSGI</remote-id>
+ <remote-id type="cpan-module">CGI::Parse::PSGI</remote-id>
+ </upstream>
+</pkgmetadata>