summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-02-03 18:15:02 -0500
committerMichael Orlitzky <mjo@gentoo.org>2017-02-03 18:15:18 -0500
commit597b7a2a168475989a9b5c21e16319dcbb886fe3 (patch)
tree3fb0cb3601b78e3fd372938c3d4877cad620caa7 /dev-php/PEAR-Text_Password
parentsys-fs/ddrescue: Bump to version 1.22 (diff)
downloadgentoo-597b7a2a168475989a9b5c21e16319dcbb886fe3.tar.gz
gentoo-597b7a2a168475989a9b5c21e16319dcbb886fe3.tar.bz2
gentoo-597b7a2a168475989a9b5c21e16319dcbb886fe3.zip
dev-php/PEAR-Text_Password: new version 1.2.1.
This new version updates to EAPI=6 and drops the php-pear-r1 eclass. Dropping the eclass was even more appropriate than usual in this case, since the package makes no use of PEAR at all. The test suite (using PHPUnit) was also enabled. The ia64, ppc, ppc64, and sparc keywords were dropped for that. Package-Manager: portage-2.3.3
Diffstat (limited to 'dev-php/PEAR-Text_Password')
-rw-r--r--dev-php/PEAR-Text_Password/Manifest2
-rw-r--r--dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.0.ebuild14
-rw-r--r--dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild30
-rw-r--r--dev-php/PEAR-Text_Password/metadata.xml11
4 files changed, 38 insertions, 19 deletions
diff --git a/dev-php/PEAR-Text_Password/Manifest b/dev-php/PEAR-Text_Password/Manifest
index 2cd0e4e96238..71979ecfffec 100644
--- a/dev-php/PEAR-Text_Password/Manifest
+++ b/dev-php/PEAR-Text_Password/Manifest
@@ -1,2 +1,2 @@
DIST Text_Password-1.1.1.tgz 4357 SHA256 018f64dd1527e6dfbd52ca86c25decfe01b1e6e86892ef0f7f171764eb850c87 SHA512 6d43b47e8ebe030c9c87e4288698f26e2ef5062bb4c4477fdc5bfe0dfbf3f9aa01b0222ca6849b82d6a33330519410694f7db1339cfc46b740fc03fb37f35b22 WHIRLPOOL b7b5efc1459dd27c283ee4b68ed8de2c859e8c5938101043b2e0f539fee3349dcb6c32f27dc6ee2b16616c8592d15e41f9938875db98a3fb079bad760f60cafc
-DIST Text_Password-1.2.0.tgz 5578 SHA256 2e8d4c75252f9dac145e4959e9bda87c86b68caada263c9ca0b326338710af91 SHA512 24acb9e9cbb1f5356c1b1f32ac55c64370f93ea8bbde093d79eebd9782d43c66e34de6edc5c7d52c1857474c494f79364b8b316d1454540397b61aa22ac22c6f WHIRLPOOL 04974cd9b179633cffc2d9fc3d883ae83a9d19b2ff97c6a05dd091f797f920b687c487a836ec1bb4a5998bae198663cda16e8c4745638df500cd47d67ae71bb1
+DIST Text_Password-1.2.1.tgz 5631 SHA256 d3c5d12f31c44759dddf7a7b61a5240c480804d90cdf01381590b893f55c1de8 SHA512 9f7a357b92b8013f41cd964245fd764c5f1347b41612aacb5fca66e4963e007d7470ea3a046e6186cfebed4960c5b6e6e23e4f2ab9e08c7aee10cba5ea347fc9 WHIRLPOOL 53f615f015e8ed392525e7dbe9d178a3d9ce5c0e430fa957fcb1cc4d2b29606acb15a085607f916560d8674b3a7e7564119dda74aefcee1e40b39c182c6ecc93
diff --git a/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.0.ebuild b/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.0.ebuild
deleted file mode 100644
index c02debf7329a..000000000000
--- a/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.0.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit php-pear-r1
-
-DESCRIPTION="Creating passwords with PHP"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
diff --git a/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild b/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
new file mode 100644
index 000000000000..edc3f2ce71da
--- /dev/null
+++ b/dev-php/PEAR-Text_Password/PEAR-Text_Password-1.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Creating passwords with PHP"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://download.pear.php.net/package/${MY_P}.tgz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Text
+}
+
+src_test() {
+ phpunit tests/ || die 'test suite failed'
+}
diff --git a/dev-php/PEAR-Text_Password/metadata.xml b/dev-php/PEAR-Text_Password/metadata.xml
index aca42932b833..6259ff8f7d3e 100644
--- a/dev-php/PEAR-Text_Password/metadata.xml
+++ b/dev-php/PEAR-Text_Password/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>php-bugs@gentoo.org</email>
- <name>PHP</name>
-</maintainer>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Text_Password</remote-id>
+ </upstream>
</pkgmetadata>