summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-uploadprogress
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-uploadprogress')
-rw-r--r--dev-php/pecl-uploadprogress/Manifest1
-rw-r--r--dev-php/pecl-uploadprogress/metadata.xml9
-rw-r--r--dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r1.ebuild21
-rw-r--r--dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r2.ebuild28
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-php/pecl-uploadprogress/Manifest b/dev-php/pecl-uploadprogress/Manifest
new file mode 100644
index 000000000000..3394d7061753
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/Manifest
@@ -0,0 +1 @@
+DIST uploadprogress-1.0.3.1.tgz 9040 SHA256 30588b4589543bcf6371532546b1a8cee9da1086c206aca9f96ea1bd486bbab2 SHA512 c317a30ed81430184b643e2755867cdccf9848312aa31a5527e4fe229ac19ee3099121de8e253207b55dd7e788c28720bd3c477663c4ca15100478647a6dc1bb WHIRLPOOL d9ddc7d67b092f620db09a14ff5ad34f300c4078ba489e7c59fd6d0121cc1441bc03ea9c960c6a9ff51899a6e9e8c472047c96f314c2f6863492efc2084abaa4
diff --git a/dev-php/pecl-uploadprogress/metadata.xml b/dev-php/pecl-uploadprogress/metadata.xml
new file mode 100644
index 000000000000..6299f7039419
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>php</herd>
+<longdescription lang="en">An extension to track progress of a file upload.
+See http://cvs.php.net/viewvc.cgi/pecl/uploadprogress/examples/ for a little example. It is only known to work on Apache with mod_php, other SAPI implementations unfortunately still have issues.
+</longdescription>
+</pkgmetadata>
+
diff --git a/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r1.ebuild b/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r1.ebuild
new file mode 100644
index 000000000000..b08e9a91171d
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_PHP="php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An extension to track progress of a file upload"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[apache2]"
+
+pkg_postinst() {
+ elog "This extension is only known to work on Apache with mod_php."
+}
diff --git a/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r2.ebuild b/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r2.ebuild
new file mode 100644
index 000000000000..2850bc43cffd
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2
+
+DESCRIPTION="An extension to track progress of a file upload"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+for target in ${USE_PHP}; do
+ slot=${target/php}
+ slot=${slot/-/.}
+ PHPUSEDEPEND="${PHPUSEDEPEND}
+ php_targets_${target}? ( dev-lang/php:${slot}[apache2] )"
+done
+
+RDEPEND="${PHPUSEDEPEND}"
+
+pkg_postinst() {
+ elog "This extension is only known to work on Apache with mod_php."
+}