summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-07 10:03:09 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-07 10:05:00 -0500
commit4791342f9374ca60a2dee260b4b186f4c0731dd9 (patch)
treeda755f5acc74a628c7ba269081e2f16e4782b2b7 /dev-php
parentdev-php/pecl-ssh2: Drop old (diff)
downloadgentoo-4791342f9374ca60a2dee260b4b186f4c0731dd9.tar.gz
gentoo-4791342f9374ca60a2dee260b4b186f4c0731dd9.tar.bz2
gentoo-4791342f9374ca60a2dee260b4b186f4c0731dd9.zip
dev-php/pecl-stomp: Version bumps removing php 5.4 and 5.4 adding 7.0
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-stomp/Manifest2
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-1.0.9.ebuild49
-rw-r--r--dev-php/pecl-stomp/pecl-stomp-2.0.0.ebuild49
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-php/pecl-stomp/Manifest b/dev-php/pecl-stomp/Manifest
index ffb451768d94..d1cebfd0a122 100644
--- a/dev-php/pecl-stomp/Manifest
+++ b/dev-php/pecl-stomp/Manifest
@@ -1 +1,3 @@
DIST stomp-1.0.8.tgz 21837 SHA256 4e75c7baeff1de84b806a3fc17f486f773a8fd94797390c0678a11f71abf16c1 SHA512 5d74b1ce230305728be91808921a4c9a0408618bcd1a896f8bb4dc35d06fc4577f3aa15ec6252685a48891a302809651a055bf5e40548ef995a256f02a59c9e7 WHIRLPOOL e453ea95274933c136452759a660f045c300876c8a75c71085b4602e76e38ae4efbbfb0857e7da4429065f6a7e6dadf020dc6db239666a796770569b5f2fa04a
+DIST stomp-1.0.9.tgz 23166 SHA256 7a7d748c6327ef8c6853dcadaedd41b4366ff821b401b11fab7b915cb5246575 SHA512 e3ab5bfb03c29edde63de4006b448e0204efbac5817b1443ee5b1a0249c2f96d58443847b878e838108b66e5307f6e803f807aff7430af748af4994bfca5199a WHIRLPOOL 0812a75f7e0ee7b8eeb87cbcc29eb68a33035d05aec56432eceb550c1caec3df1dcba683e2bca386a1aae26c3de1878dcfc401ede59f7b9bedb69447cdf63cdf
+DIST stomp-2.0.0.tgz 23422 SHA256 7a51195b26e2178bcdacd4ae09023cf50c756964fea85bf3837ab0b2ea7fa727 SHA512 f999762f842f19e920bca35175e65e20173c9ef5162eba3b79a7a2a70a52991c5d39f6d9dd6d9dfa081f1c2fb23e0dae5fa42224dcad4626666e5785076f1a12 WHIRLPOOL d7f5422a45982de5b9baded1c6c0105d631a10ceeda8ef1ea7902ffe0efb95b31e82b461aaaafe8c73795cd2c334d51e3e8eac90873f058d1c8e8cd41e118954
diff --git a/dev-php/pecl-stomp/pecl-stomp-1.0.9.ebuild b/dev-php/pecl-stomp/pecl-stomp-1.0.9.ebuild
new file mode 100644
index 000000000000..2ac7efc2c9db
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-1.0.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+USE_PHP="php5-6 php7-0"
+PHP_EXT_NAME="stomp"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp compliant Message Brokers"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE="examples +ssl"
+
+DEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-lang/php:5.6[ssl?] )
+"
+
+RDEPEND="${DEPEND}"
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-stomp:7 )"
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( --enable-stomp
+ $(use_with ssl openssl-dir=/usr) )
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}
diff --git a/dev-php/pecl-stomp/pecl-stomp-2.0.0.ebuild b/dev-php/pecl-stomp/pecl-stomp-2.0.0.ebuild
new file mode 100644
index 000000000000..08bd34979fb2
--- /dev/null
+++ b/dev-php/pecl-stomp/pecl-stomp-2.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+USE_PHP="php5-6 php7-0"
+PHP_EXT_NAME="stomp"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS=( CREDITS doc/classes.php doc/functions.php )
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php7-0"
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP extension to communicate with Stomp compliant Message Brokers"
+LICENSE="PHP-3"
+SLOT="7"
+IUSE="examples +ssl"
+
+DEPEND="${DEPEND}
+ php_targets_php7-0? ( dev-lang/php:7.0[ssl?] )
+"
+
+RDEPEND="${DEPEND}
+ php_targets_php5-6? ( dev-php/pecl-stomp:0 )"
+
+src_prepare() {
+ if use php_targets_php7-0 ; then
+ php-ext-source-r3_src_prepare
+ else
+ default_src_prepare
+ fi
+}
+
+src_configure() {
+ local PHP_EXT_ECONF_ARGS=( --enable-stomp
+ $(use_with ssl openssl-dir=/usr) )
+ php-ext-source-r3_src_configure
+}
+
+src_install() {
+ if use php_targets_php7-0 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}