summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-15 15:42:19 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-15 15:42:19 +0200
commit40deaf8385d15f9c681bb4da06219785488d49e0 (patch)
tree1efb7f715bd27dbeb84e2f9334d06e7c4edf1eb3 /dev-python/aiodns
parentdev-python/pycares: Restore RESTRICT=test (diff)
downloadgentoo-40deaf8385d15f9c681bb4da06219785488d49e0.tar.gz
gentoo-40deaf8385d15f9c681bb4da06219785488d49e0.tar.bz2
gentoo-40deaf8385d15f9c681bb4da06219785488d49e0.zip
dev-python/aiodns: Bump to 1.2.0, py3.7, EAPI 7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aiodns')
-rw-r--r--dev-python/aiodns/Manifest1
-rw-r--r--dev-python/aiodns/aiodns-1.2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/aiodns/Manifest b/dev-python/aiodns/Manifest
index a64ae169c5c1..300d641b6e0e 100644
--- a/dev-python/aiodns/Manifest
+++ b/dev-python/aiodns/Manifest
@@ -1 +1,2 @@
DIST aiodns-1.1.1.tar.gz 6084 BLAKE2B 8e58cedcf288f87ca9cc8d5f067bdf182f220979aba3d2aa53eb998ae877dcaa7c2a7419a50719ba150fdf17271d025668b28a3212fc5a819bf13129b4fb25a2 SHA512 4bd8b80a10f84b82b13ba4ff6abbb1afd13ba6cfececc4db7c4bd303569473316f1c0e083f1017a450875fc8994a70c30c9a1b3fb2278fee5e27158973bc3810
+DIST aiodns-1.2.0.tar.gz 6457 BLAKE2B c1035e5a31b179665be1c7c75e3e8f6665e04c43d5f2bada7e0d7ef76f17d99d2d86c2bd5063fbda2d2947c7a4aa1e21e66cef070019da6bf56e94d716edc0ea SHA512 2e80c275d98f54378b121cafe4680221f29eb57346976b3c476c7110fcb215892744982de25736193663ab4ac3f3cf516fa38b664e3303e6c67180ed6c31e21b
diff --git a/dev-python/aiodns/aiodns-1.2.0.ebuild b/dev-python/aiodns/aiodns-1.2.0.ebuild
new file mode 100644
index 000000000000..3f3766200b23
--- /dev/null
+++ b/dev-python/aiodns/aiodns-1.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+# Tests fail with network-sandbox, since they try to resolve google.com
+RESTRICT="test"
+
+RDEPEND="dev-python/pycares[${PYTHON_USEDEP}]
+$(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' -2)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ "${EPYTHON}" tests.py -v || die
+}