summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-07-17 17:34:06 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-07-17 17:44:30 +0200
commit1f7c92f6b95f2dcbe7531a929739ab617eb9e4d2 (patch)
treeb36a64a017d5a40e66dc450607b5596ec5176b78 /dev-python/bleach
parentdev-python/bcrypt: Bump (diff)
downloadgentoo-1f7c92f6b95f2dcbe7531a929739ab617eb9e4d2.tar.gz
gentoo-1f7c92f6b95f2dcbe7531a929739ab617eb9e4d2.tar.bz2
gentoo-1f7c92f6b95f2dcbe7531a929739ab617eb9e4d2.zip
dev-python/bleach: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-1.4.3.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 1b9b22aad3b7..9731ee5953c9 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1,2 +1,3 @@
DIST bleach-1.4.1.tar.gz 17449 SHA256 152af29d4580b112fc52966864492791c951e6382b56070e95e128c6b614833b SHA512 247dd02e3123149f8c0dd72e91e3942055d560be791f275ce52ce0250406033b2adfb47e257cb6af2dfd3dfc167ed6434c4cf4b906303e2cd96359d77b55482c WHIRLPOOL 015b4fb0d825201cc59188caf8d94e3d3b1af336ee3f0c787e07d8a73ec32f727c6640828e694b21e2dd255253416e25e11e44d8932bbbca5571494096b75020
DIST bleach-1.4.2.tar.gz 17876 SHA256 56018a17d1488eb1a1e18e7cdddcaea24d3c7b3704172e356f6916c577f4fd9e SHA512 cff3fdb585279bc4bbc11b70fb54e4e99ab4f4afb0d4a7d01e0b10e86d501464324a154b06bfd4f98517c8d1561f2a95a03054e59c661c56a2e3e5dc13788b3a WHIRLPOOL d31e28cad84381ca3fa42e77059eb2f99e2c6c77e02fb293ce0b6552fd962057f4058ab1ad9e49a28a52266633f4891d4f740566de81c9069419cf29614d7aec
+DIST bleach-1.4.3.tar.gz 18094 SHA256 1293061adb5a9eebb7b260516e691785ac08cc1646c8976aeda7db9dbb1c6f4b SHA512 316450f6325c4fba78de97ba755c185d59aa4d112f303d9f630918f02e613170c2e6bc6ce2de73ce3b0000572de673ab0e0dddbe41da59de5f4cebbfa1348a14 WHIRLPOOL 48a591bdd5b2b91ccc9fa1efe3eb59215d06aa9fa8cb2efeaa352afd5f62e0002185ad99745814c7622e3e7f9645c159267f12e43752df7eed5726a3d01de2f6
diff --git a/dev-python/bleach/bleach-1.4.3.ebuild b/dev-python/bleach/bleach-1.4.3.ebuild
new file mode 100644
index 000000000000..9d4f2dc120f1
--- /dev/null
+++ b/dev-python/bleach/bleach-1.4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/jsocol/bleach https://pypi.python.org/pypi/bleach"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}