summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-12-13 18:45:35 -0500
committerTim Harder <radhermit@gentoo.org>2015-12-13 18:56:58 -0500
commite0989afe381c734a7eeec6cdb1efa0a425bbbca5 (patch)
treef1fe731db157622f0859bd5af0e88eb7c6f6fe20 /dev-python/bleach
parentx11-wm/page: List libraries in RDEPEND and the rest in DEPEND. Fixes bug 562632. (diff)
downloadgentoo-e0989afe381c734a7eeec6cdb1efa0a425bbbca5.tar.gz
gentoo-e0989afe381c734a7eeec6cdb1efa0a425bbbca5.tar.bz2
gentoo-e0989afe381c734a7eeec6cdb1efa0a425bbbca5.zip
dev-python/bleach: version bump to 1.4.2
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-1.4.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 065bab110d8a..1b9b22aad3b7 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-1.4.1.tar.gz 17449 SHA256 152af29d4580b112fc52966864492791c951e6382b56070e95e128c6b614833b SHA512 247dd02e3123149f8c0dd72e91e3942055d560be791f275ce52ce0250406033b2adfb47e257cb6af2dfd3dfc167ed6434c4cf4b906303e2cd96359d77b55482c WHIRLPOOL 015b4fb0d825201cc59188caf8d94e3d3b1af336ee3f0c787e07d8a73ec32f727c6640828e694b21e2dd255253416e25e11e44d8932bbbca5571494096b75020
+DIST bleach-1.4.2.tar.gz 17876 SHA256 56018a17d1488eb1a1e18e7cdddcaea24d3c7b3704172e356f6916c577f4fd9e SHA512 cff3fdb585279bc4bbc11b70fb54e4e99ab4f4afb0d4a7d01e0b10e86d501464324a154b06bfd4f98517c8d1561f2a95a03054e59c661c56a2e3e5dc13788b3a WHIRLPOOL d31e28cad84381ca3fa42e77059eb2f99e2c6c77e02fb293ce0b6552fd962057f4058ab1ad9e49a28a52266633f4891d4f740566de81c9069419cf29614d7aec
diff --git a/dev-python/bleach/bleach-1.4.2.ebuild b/dev-python/bleach/bleach-1.4.2.ebuild
new file mode 100644
index 000000000000..56945ff80b4b
--- /dev/null
+++ b/dev-python/bleach/bleach-1.4.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/jsocol/bleach https://pypi.python.org/pypi/bleach"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/html5lib-0.999[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/nose-1.3[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}