summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-11 08:49:26 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-11 09:53:12 +0200
commit030dade93e0b69ca6b5620391728f297218549ad (patch)
tree5ec3dc49519199e6258cdc86a47c6cee830969a6 /dev-python/path-py
parentdev-python/mako: Version Bump (diff)
downloadgentoo-030dade93e0b69ca6b5620391728f297218549ad.tar.gz
gentoo-030dade93e0b69ca6b5620391728f297218549ad.tar.bz2
gentoo-030dade93e0b69ca6b5620391728f297218549ad.zip
dev-python/path-py: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/path-py-8.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index 71da504a572b..207cd1aa8b82 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,2 +1,3 @@
DIST path.py-7.7.1.tar.gz 33102 SHA256 692feac9d1fe3b70239b2f0f07dcdbbdad38e3611846924de33ec6175d87638e SHA512 9275fab8340600889e0704d383f009d9aa94f9fa903aade57922b8fc797587734bdacd89ab6e87573dffd4cfa6a167067e03cfab0916cc3416619774134de7cb WHIRLPOOL 7811ccbf811c8d7a307d2cb50ddfdea2e96c49de2e1618c856d97f300560cca3558c2fa2a1cf29717cfbdb4460f05f7fe8d5dbd9efadba3ae76e4f526d3c7b53
+DIST path.py-8.1.1.tar.gz 33292 SHA256 2e109f902aed4a7999d465e4ec8456c1112e657840520c5bc7104fb7050d1add SHA512 7a33807017c952d347bb966e1ed6db49e30625c7b2ae795dc11b39a237830d988f2d3033666da9a796cb5048ab8024690c803054f40cc21b0ce1a68fe9969802 WHIRLPOOL a18277816f9fbe3042fa397b63203a3b4696f657414c2c72ee656679e24ec86363f493e8e31ff50721a52a6e2d3afee31f75a730f325e22ca4f071c4ff988681
DIST path.py-8.1.tar.gz 33221 SHA256 27ea0789c12cbe8e2a29397d2a54581009094a0684ce880844ba9fc4c16ce30c SHA512 f5a2e824bdf7c097fc690ce57237dc476e0c2b748dd6c7b1559d4d769bef2485a5bfddcad6ae89af861a0e072fc16eeefea307a0c3e069fa30b9e4e90b9a742f WHIRLPOOL e8c307bfbdfd0c61e2d09c21689120e4c1986b230daa56c51b56d94329149a32870f37cec3ccd1fdee12d8c40cd2f38ec90de1dfdecfad3d73f233004551368b
diff --git a/dev-python/path-py/path-py-8.1.1.ebuild b/dev-python/path-py/path-py-8.1.1.ebuild
new file mode 100644
index 000000000000..b490b2b7e6e1
--- /dev/null
+++ b/dev-python/path-py/path-py-8.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="http://pythonhosted.org/path.py https://pypi.python.org/pypi/path.py https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ sed '/setuptools_scm/d' -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py test
+}