summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/path-py
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest2
-rw-r--r--dev-python/path-py/metadata.xml9
-rw-r--r--dev-python/path-py/path-py-7.2.ebuild31
-rw-r--r--dev-python/path-py/path-py-7.3.ebuild31
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
new file mode 100644
index 000000000000..fc2d054e84a8
--- /dev/null
+++ b/dev-python/path-py/Manifest
@@ -0,0 +1,2 @@
+DIST path.py-7.2.zip 33360 SHA256 5e2330895ff3a7873c90cf2600da51b0baae0a3d5fd3ce47d22b32b15db65e1f SHA512 b3c810305e04a4167d86a0732a3fdfd95e545252fa0ade3eb9d41ce76d5e2cc7b0396a707af99c9ab475a2fcb7df2ea3858cfe183ba8da25217fe9f27855392f WHIRLPOOL 72a753879a6420dce2d504dffe1f1c7f10f53819a7c7f8e7b10b29e106083f02005ac2824b40e556392591592eaead17adc33f221eeec875d066bb5ed6685600
+DIST path.py-7.3.zip 33549 SHA256 f7d146f40768e3742199a5316fbe3eb6a6091b9feedcb4b969c7348dc03151e1 SHA512 f676b81deda7b42a2a29fef0827d7c8ecbe743d0fa5efdc8221a78f3e744f357a179a9b8451264636ca2626f58d422a02d6ad77cc57eef74dd3b186585863433 WHIRLPOOL 7da96c488aa6bcdea0a65c69b412710dbc85f7bed04dd571389ca190d43fea2e711659ca3546b926efc69d631a1408b5905839c39866d7e98b7dde19803d0c4f
diff --git a/dev-python/path-py/metadata.xml b/dev-python/path-py/metadata.xml
new file mode 100644
index 000000000000..d1a9051ef223
--- /dev/null
+++ b/dev-python/path-py/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">path.py</remote-id>
+ <remote-id type="github">jaraco/path.py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/path-py/path-py-7.2.ebuild b/dev-python/path-py/path-py-7.2.ebuild
new file mode 100644
index 000000000000..8b4f05706610
--- /dev/null
+++ b/dev-python/path-py/path-py-7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="http://pythonhosted.org/path.py https://pypi.python.org/pypi/path.py https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.zip"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/path-py/path-py-7.3.ebuild b/dev-python/path-py/path-py-7.3.ebuild
new file mode 100644
index 000000000000..8b4f05706610
--- /dev/null
+++ b/dev-python/path-py/path-py-7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_P="path.py-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="http://pythonhosted.org/path.py https://pypi.python.org/pypi/path.py https://github.com/jaraco/path.py"
+SRC_URI="mirror://pypi/p/path.py/${MY_P}.zip"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}