summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2015-10-11 11:05:47 +0200
committerDirkjan Ochtman <djc@gentoo.org>2015-10-11 11:05:47 +0200
commit357ab6dc3372f7c12659966a30cf118a31897e43 (patch)
tree0091ab689902f80a0c40f08966346cbb2c4d7a14 /dev-python/rply
parentdev-python/six: version bump to 1.10.0 (diff)
downloadgentoo-357ab6dc3372f7c12659966a30cf118a31897e43.tar.gz
gentoo-357ab6dc3372f7c12659966a30cf118a31897e43.tar.bz2
gentoo-357ab6dc3372f7c12659966a30cf118a31897e43.zip
dev-python/rply: version bump to 0.7.4
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/rply')
-rw-r--r--dev-python/rply/Manifest1
-rw-r--r--dev-python/rply/rply-0.7.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rply/Manifest b/dev-python/rply/Manifest
index 66cd92cfe6d4..d10c4ea0c13c 100644
--- a/dev-python/rply/Manifest
+++ b/dev-python/rply/Manifest
@@ -1 +1,2 @@
DIST rply-0.7.3.tar.gz 27346 SHA256 708f94da2cf5df72b0d0fe73a44a6f2310dd74004b0e7ef6bf812f941dac582a SHA512 45f8b2b9fb84940c1149b43ffda070d7ded47a5b8d8e86cf030603cb0fae78df954e629d9e6722e8f4d5ff2a7a2d516a92cf320d438cb6b1595d110e06dfc351 WHIRLPOOL b1c55fc76f0f6c7afae5dbce336a6a7510ed38ecd3c81ab22f19d9657c9f3547c8297028c35a60931db0197fdc0fee7cb1e7c50bad6769bba413247d759508da
+DIST rply-0.7.4.tar.gz 27392 SHA256 5fe9fc7c24dc3cfcaf443ef84fddcf420132746e64eced79b6735e7927e80329 SHA512 e3c3a828eb4b3cb20751ecb2d91efaabddbe3702d52b9adefe1748c07c843da1899e3944bcf0ab79f627ae428b8879cf99739ea7e0c6fd1acffc4ac4dee1b652 WHIRLPOOL 5d1cf3abf224a03a6210254577f388367b41c645fe4464e27e6c3537f933c79d6d004c33765c76a307973b5afde8954266da6d9bb6e850e841b9a987cc7f2e6c
diff --git a/dev-python/rply/rply-0.7.4.ebuild b/dev-python/rply/rply-0.7.4.ebuild
new file mode 100644
index 000000000000..0d09e28f604d
--- /dev/null
+++ b/dev-python/rply/rply-0.7.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python parser generator that also works with RPython"
+HOMEPAGE="https://github.com/alex/rply"
+SRC_URI="https://github.com/alex/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare() {
+ # https://github.com/alex/rply/issues/26; fail under py[3-4]
+ if python_is_python3; then
+ sed -e s':test_simple:_&:' -e s':test_empty_production:_&:' \
+ -i tests/test_parsergenerator.py
+ fi
+ distutils-r1_python_prepare
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}