summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/suds
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/suds')
-rw-r--r--dev-python/suds/Manifest2
-rw-r--r--dev-python/suds/metadata.xml10
-rw-r--r--dev-python/suds/suds-0.4-r1.ebuild32
-rw-r--r--dev-python/suds/suds-0.6-r1.ebuild51
-rw-r--r--dev-python/suds/suds-0.6.ebuild31
5 files changed, 126 insertions, 0 deletions
diff --git a/dev-python/suds/Manifest b/dev-python/suds/Manifest
new file mode 100644
index 000000000000..f9fbfb71a012
--- /dev/null
+++ b/dev-python/suds/Manifest
@@ -0,0 +1,2 @@
+DIST suds-0.4.tar.gz 104013 SHA256 d5524ae523bb9e09c57bcdbd1efae2c287d20603688ea31f6020ed180a489af0 SHA512 5ec53c3e834947a394fec8d51b497d6e5824fd5e6e51addce98d552cfa692cac99e159e270d247fff98a0f669506f4c179fad3f43452600bae1db08f851dec1b WHIRLPOOL 84a63b343e96d06f85757b97c51582305ec0d6d634171260723cafc356b76266f0f2ece5f16ea6772a35a76f0587a15871e3801eb53db7171c5761d74b4ecc18
+DIST suds-0.6.tar.bz2 143985 SHA256 29edb72fd21e3044093d86f33c66cf847c5aaab26d64cb90e69e528ef014e57f SHA512 ec078b159bd83c5799e293d9607138ee1da90fdc64da203999555a4324ce7be0235156d3c7ad28e46f84180a6e51e2f3f82228e5e77ae41c61ee20f3db2c916b WHIRLPOOL 9c62762f1c865cf7763d9a7332dfa9927dcb693a99414de063451a11581a7e303b19c3c0f840db339829bd59c116565fba26d98aaa520739a6aa84edaabc90aa
diff --git a/dev-python/suds/metadata.xml b/dev-python/suds/metadata.xml
new file mode 100644
index 000000000000..ec200de66966
--- /dev/null
+++ b/dev-python/suds/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">A lightweight SOAP python client for consuming Web Services.</longdescription>
+ <upstream>
+ <remote-id type="pypi">suds</remote-id>
+ <remote-id type="bitbucket">jurko/suds</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/suds/suds-0.4-r1.ebuild b/dev-python/suds/suds-0.4-r1.ebuild
new file mode 100644
index 000000000000..2a05169a5462
--- /dev/null
+++ b/dev-python/suds/suds-0.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client"
+HOMEPAGE="https://fedorahosted.org/suds/ http://pypi.python.org/pypi/suds"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_compile_all() {
+ if use doc; then
+ epydoc -n "Suds - ${DESCRIPTION}" -o doc suds || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/suds/suds-0.6-r1.ebuild b/dev-python/suds/suds-0.6-r1.ebuild
new file mode 100644
index 000000000000..f38a4629c560
--- /dev/null
+++ b/dev-python/suds/suds-0.6-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client (Jurko's fork) (py3 support) (active development)"
+HOMEPAGE="http://bitbucket.org/jurko/suds"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}-jurko/${PN}-jurko-${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-jurko-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+REQUIRED_USE="doc? ( $(python_gen_useflags python2_7) )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/epydoc[$(python_gen_usedep python2_7)] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( README.rst notes/{argument_parsing.rst,readme.txt,traversing_client_data.rst} )
+
+python_compile_all() {
+ # to say that it's both, because it kinda is...
+ ! use doc || epydoc -n "Suds - ${DESCRIPTION}" -o doc suds || die
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ # test folder makes for file collisions by the eclass
+ sed -i -e '/^tests/d' suds_jurko.egg-info/top_level.txt suds_jurko.egg-info/SOURCES.txt || die
+ cp -r suds_jurko.egg-info suds.egg-info || die
+ sed -i -e 's/Name\:\ suds-jurko/Name:\ suds/g' -e '/^Obsoletes/d' suds.egg-info/PKG-INFO || die
+ rm -rf ./{tests,build/lib/tests,lib/tests}/ || die
+ distutils-r1_python_install
+}
diff --git a/dev-python/suds/suds-0.6.ebuild b/dev-python/suds/suds-0.6.ebuild
new file mode 100644
index 000000000000..accbbcdb4df6
--- /dev/null
+++ b/dev-python/suds/suds-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client (Jurko's fork) (py3 support) (active development)"
+HOMEPAGE="http://bitbucket.org/jurko/suds"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}-jurko/${PN}-jurko-${PV}.tar.bz2 -> ${P}.tar.bz2"
+S="${WORKDIR}/${PN}-jurko-${PV}"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare() {
+ rm -R tests
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ mv suds_jurko.egg-info suds.egg-info || die
+ sed -i -e 's/Name\:\ suds-jurko/Name:\ suds/g' -e '/^Obsoletes/d' suds.egg-info/PKG-INFO || die
+}