summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-28 17:04:20 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-28 17:05:55 +0300
commit01907897a63513a9a112097800e1dbbf97bde8da (patch)
treedce1cb69f024e7814edde62d019866b74691049d /dev-python
parentmedia-libs/libmtp: x86 stable wrt bug #820326 (diff)
downloadgentoo-01907897a63513a9a112097800e1dbbf97bde8da.tar.gz
gentoo-01907897a63513a9a112097800e1dbbf97bde8da.tar.bz2
gentoo-01907897a63513a9a112097800e1dbbf97bde8da.zip
dev-python/yamlpath: add 3.6.3, EAPI=8, clean ebuild
- use d_e_t for tests - tests need dev-ruby/hiera-eyaml - use exclude in find_packages instead of removing after install - move the installing of yamlpath/patches/aliasstyle.py into python_install Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/yamlpath/Manifest1
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
index 4fb29dcb8eb1..eed54223b967 100644
--- a/dev-python/yamlpath/Manifest
+++ b/dev-python/yamlpath/Manifest
@@ -1 +1,2 @@
DIST yamlpath-3.6.1.tar.gz 214053 BLAKE2B 5c72ffc4e4307f1a3fea7a697782c432402acc1ee929de34a702188d51287fd7187b688354533163b7101dc17ed394f0e2681a1a194807f00762bf6c71387292 SHA512 8ef8e1931118ed881d52b6d7f589b1c671694c211cb1c988e7e6945b7ff5408163bd402f52c1815b453bf8ccc61e8b8ed5c19a00be076d8e76e0a037461a12e2
+DIST yamlpath-3.6.3.gh.tar.gz 214734 BLAKE2B fd36d276831771c81272a2bb60a9fe7995c63f1026143925e34167ee397b56725ec9ba5d5afac2a85121512b8f8da3f988fd022dc2378ee80b91567f15d95c1a SHA512 b6c41b550339809e3a0bcbd7dca190956f06799303c1c12bb68eed567c56ccafd2acc2a8a6ab33fb03abde61b3de25673ee2d459f6d66e6782f9325212653ade
diff --git a/dev-python/yamlpath/yamlpath-3.6.3.ebuild b/dev-python/yamlpath/yamlpath-3.6.3.ebuild
new file mode 100644
index 000000000000..aee7c4907046
--- /dev/null
+++ b/dev-python/yamlpath/yamlpath-3.6.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Command-line processors for YAML/JSON/Compatible data."
+HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
+SRC_URI="
+ https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-ruby/hiera-eyaml
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e '/ruamel\.yaml/d' \
+ -e '/pytest-cov/d' \
+ -e "/find_packages/s/()/(exclude=\['tests'\])/" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install and optimize yamlpath/patches/aliasstyle.py
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ insinto "${sitedir}/yamlpath"
+ doins -r "${S}/yamlpath/patches"
+ python_optimize "${D}${sitedir}"
+}