summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-31 13:38:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 13:39:29 +0200
commit88c2e58e21bfa18a50f814b1a0bde5a0a5eda2ed (patch)
tree5091a1677f954efbde284c7473ffa2c14838e081 /dev-python
parentdev-python/pypy3_10-exe-bin: Split from dev-python/pypy3-exe-bin, 7.3.12_rc2 (diff)
downloadgentoo-88c2e58e21bfa18a50f814b1a0bde5a0a5eda2ed.tar.gz
gentoo-88c2e58e21bfa18a50f814b1a0bde5a0a5eda2ed.tar.bz2
gentoo-88c2e58e21bfa18a50f814b1a0bde5a0a5eda2ed.zip
dev-python/pypy3: Bump to 7.3.12_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild26
-rw-r--r--dev-python/pypy3/pypy3-7.3.12_rc2.ebuild26
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild b/dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild
new file mode 100644
index 000000000000..07644e35c8be
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.12_rc2-r100.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYVER=3.10
+DESCRIPTION="A fast, compliant alternative implementation of the Python (${PYVER}) language"
+HOMEPAGE="
+ https://www.pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0/pypy310-pp73-384"
+KEYWORDS=""
+IUSE="+gdbm ncurses sqlite tk"
+
+RDEPEND="
+ =dev-python/pypy3_10-${PV}*:${SLOT}[gdbm?,ncurses?,sqlite?,tk?]
+"
+
+src_install() {
+ dodir /usr/bin
+ dosym pypy${PYVER} /usr/bin/pypy3
+}
diff --git a/dev-python/pypy3/pypy3-7.3.12_rc2.ebuild b/dev-python/pypy3/pypy3-7.3.12_rc2.ebuild
new file mode 100644
index 000000000000..974f09d809f6
--- /dev/null
+++ b/dev-python/pypy3/pypy3-7.3.12_rc2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYVER=3.9
+DESCRIPTION="A fast, compliant alternative implementation of the Python (${PYVER}) language"
+HOMEPAGE="
+ https://www.pypy.org/
+ https://foss.heptapod.net/pypy/pypy/
+"
+S=${WORKDIR}
+
+LICENSE="MIT"
+SLOT="0/pypy39-pp73-336"
+KEYWORDS=""
+IUSE="+gdbm ncurses sqlite tk"
+
+RDEPEND="
+ =dev-python/pypy3_9-${PV}*:${SLOT}[gdbm?,ncurses?,sqlite?,tk?]
+"
+
+src_install() {
+ dodir /usr/bin
+ dosym pypy${PYVER} /usr/bin/pypy3
+}