summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:24:12 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-08-15 17:28:30 +0000
commit90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3 (patch)
treeb5fe0b29d0f78eff825acb909bb5dd5e0bffb274 /dev-python
parentdev-python/ipython: version bump, python-3* only (diff)
downloadgentoo-90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3.tar.gz
gentoo-90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3.tar.bz2
gentoo-90fd0e8238a7cddc3391ba93b3e8dc6bf317e2c3.zip
dev-python/pytest-cython: initial import
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-cython/Manifest1
-rw-r--r--dev-python/pytest-cython/metadata.xml12
-rw-r--r--dev-python/pytest-cython/pytest-cython-0.1.0.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytest-cython/Manifest b/dev-python/pytest-cython/Manifest
new file mode 100644
index 000000000000..5c7333185e2e
--- /dev/null
+++ b/dev-python/pytest-cython/Manifest
@@ -0,0 +1 @@
+DIST pytest-cython-0.1.0.tar.gz 19109 SHA256 90fa7e4e619bababeb433d3ba173a80d20473cce0bf3dce2c0e6f298becf5998 SHA512 65d8d25f95f2419ae76902cad8f0f4c9b810dbbba80621d301f53d2128dfeb11c4d74e2ac4f1e39f63aadfc1404e9000c0668efbab4793d307f0b90345023771 WHIRLPOOL 1d360c1dfafd6059c75741e984ce3d6a7a09bb8ff0135c8d318d8ba345c59e21d16a83a52c2a7ce222dc7ea58bc13fd6ab5e8fd32fa4df22154086e977608d2c
diff --git a/dev-python/pytest-cython/metadata.xml b/dev-python/pytest-cython/metadata.xml
new file mode 100644
index 000000000000..535d87310a6a
--- /dev/null
+++ b/dev-python/pytest-cython/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pytest-cython</remote-id>
+ <remote-id type="github">lgpage/pytest-cython</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
new file mode 100644
index 000000000000..60ca2ab4411f
--- /dev/null
+++ b/dev-python/pytest-cython/pytest-cython-0.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin for testing Cython extension modules"
+HOMEPAGE="https://github.com/lgpage/pytest-cython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"