summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-03 12:41:05 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-04 00:36:57 +1100
commit30bf416f5c909f3bc8d09ca5761529e97f441d2a (patch)
treeffad87efb451c904c3c3aad4c1dbcc8a19f5cb5e /dev-qt/qtimageformats
parentqt5-build.eclass: introduce QT5_GENTOO_PRIVATE_CONFIG (diff)
downloadgentoo-30bf416f5c909f3bc8d09ca5761529e97f441d2a.tar.gz
gentoo-30bf416f5c909f3bc8d09ca5761529e97f441d2a.tar.bz2
gentoo-30bf416f5c909f3bc8d09ca5761529e97f441d2a.zip
dev-qt: version bump 5.9.4
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-qt/qtimageformats')
-rw-r--r--dev-qt/qtimageformats/Manifest1
-rw-r--r--dev-qt/qtimageformats/qtimageformats-5.9.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/Manifest b/dev-qt/qtimageformats/Manifest
index 70999c946839..2e68aa213676 100644
--- a/dev-qt/qtimageformats/Manifest
+++ b/dev-qt/qtimageformats/Manifest
@@ -1,2 +1,3 @@
DIST qtimageformats-opensource-src-5.7.1.tar.xz 2004376 BLAKE2B 9cc015133ca70dc6d6e542e9c10921352b5c1e529ea03165e0b0443e679fee8987d2fb4f4ec430d0ae164b77b50029e61f149e063501a6f855fcc78050cfc4c9 SHA512 b70fe30b20da8f613f05ae68bf879956341206005d1eff3c34fc279da6b219ff7983d41c2c0c057c85500a2c5826286c63f4c209dc2db84d03848241257be553
DIST qtimageformats-opensource-src-5.9.3.tar.xz 2102504 BLAKE2B 46fdbb00177e6feb7fdf38595026bb4b87053b6158e20ab06d7150e1b9ed88ef6ebca93cc396240194f2c6feca9613153abd88f49949f1e4956f9665d368e2a4 SHA512 521c805635084fba3746ee86ac7dfc94d2446114dd76aecad6a6f0cb97f49e443f078f2e0439a10a9d3d5fcd285136959b740707fb8d7776b0450f964950a864
+DIST qtimageformats-opensource-src-5.9.4.tar.xz 2106852 BLAKE2B 31f0f5d6c545f04b2be4bd657acce63adb15a45d4b0471b249e39063ae47635a8c5338f44cc0af88ca0c960d399384a911add12f7cd2815c808ddc28d7f5e924 SHA512 91ebe0d4cc67b3d3c55da4dd5d08028f7046819fdc4034ed0ddec075443ebe3775690856a7aa7704ee3ad8893948f79bdc72467fdfea6a0a8ce6fb16b3f5ab5a
diff --git a/dev-qt/qtimageformats/qtimageformats-5.9.4.ebuild b/dev-qt/qtimageformats/qtimageformats-5.9.4.ebuild
new file mode 100644
index 000000000000..5b10805b2ac2
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-5.9.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+fi
+
+IUSE="jpeg2k mng"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ media-libs/libwebp:=
+ media-libs/tiff:0
+ jpeg2k? ( media-libs/jasper:= )
+ mng? ( media-libs/libmng:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ qt_use_compile_test jpeg2k jasper
+ qt_use_compile_test mng libmng
+ qt5-build_src_configure
+}