summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-30 00:50:28 +0100
committerSam James <sam@gentoo.org>2024-04-30 00:50:49 +0100
commite209990c6d94a01863c46f3285cdd18d0ec98201 (patch)
tree00e186da58ff33679e70623d1e828b7ea06484c7 /dev-qt
parentmedia-gfx/inkscape: add missing dependency (diff)
downloadgentoo-e209990c6d94a01863c46f3285cdd18d0ec98201.tar.gz
gentoo-e209990c6d94a01863c46f3285cdd18d0ec98201.tar.bz2
gentoo-e209990c6d94a01863c46f3285cdd18d0ec98201.zip
dev-qt/qtwebengine: fix build w/ ninja-1.12 for qt5
Same as Ionen's patch for qt6 but with a hunk removed. Closes: https://bugs.gentoo.org/930107 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240322-ninja1.12.patch23
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.13_p20240322.ebuild5
2 files changed, 27 insertions, 1 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240322-ninja1.12.patch b/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240322-ninja1.12.patch
new file mode 100644
index 000000000000..2da3dc27fab2
--- /dev/null
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.15.13_p20240322-ninja1.12.patch
@@ -0,0 +1,23 @@
+Quoting the description from qtwebengine-6.7.0-ninja1.12.patch:
+"""
+Patch status: pending being looked at upstream
+
+Issue[1][2][3] also exist in chromium itself[4], and unclear
+why this started happening only with ninja-1.12.0 at the moment.
+
+Just a quickfix, likely not fully correct and seems there may
+be further unresolved race issues.
+
+[1] https://bugs.gentoo.org/930107
+[2] https://bugreports.qt.io/browse/QTBUG-124375
+[3] https://github.com/ninja-build/ninja/issues/2417
+[4] https://bugs.gentoo.org/930112
+"""
+
+This has a hunk removed but is otherwise the same.
+--- a/src/3rdparty/chromium/content/browser/BUILD.gn
++++ b/src/3rdparty/chromium/content/browser/BUILD.gn
+@@ -198,2 +198,3 @@
+ "//components/services/storage/public/mojom",
++ "//components/spellcheck:buildflags",
+ "//components/sqlite_proto",
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.13_p20240322.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.13_p20240322.ebuild
index 22bb5cdc0734..c8cd5e9574d1 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.13_p20240322.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.13_p20240322.ebuild
@@ -98,7 +98,10 @@ BDEPEND="${PYTHON_DEPS}
sys-devel/flex
"
-PATCHES=( "${WORKDIR}/${PATCHSET}" )
+PATCHES=(
+ "${WORKDIR}/${PATCHSET}"
+ "${FILESDIR}"/qtwebengine-5.15.13_p20240322-ninja1.12.patch
+)
qtwebengine_check-reqs() {
# bug #307861