summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 14:55:00 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 15:07:21 +0200
commite28eaebb7a5c3bffed080812b537612c2bcd4569 (patch)
treeec0bc3abe102f47c7af204bba045a218852dc9d3 /dev-ros/calibration_estimation
parentsci-physics/lammps: Version bump (diff)
downloadgentoo-e28eaebb7a5c3bffed080812b537612c2bcd4569.tar.gz
gentoo-e28eaebb7a5c3bffed080812b537612c2bcd4569.tar.bz2
gentoo-e28eaebb7a5c3bffed080812b537612c2bcd4569.zip
dev-ros/calibration_estimation: Bump to 0.10.14.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/calibration_estimation')
-rw-r--r--dev-ros/calibration_estimation/Manifest1
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/Manifest b/dev-ros/calibration_estimation/Manifest
index 389070489594..93fa7e068080 100644
--- a/dev-ros/calibration_estimation/Manifest
+++ b/dev-ros/calibration_estimation/Manifest
@@ -1 +1,2 @@
DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
+DIST calibration-0.10.14.tar.gz 112475 SHA256 1e65e6d8f793e7a27d1975ec3c4b63bf5249c7ce859dd11187258560901d1c77 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40 WHIRLPOOL 5c1ea989d438198044933927acfd7eb8426c9f5f253710ac63117b2a20c526acfea568f4b7b4f1930a43024bbcf4033f0f04c9e48108dc7e1cc629fb9e3c127f
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
new file mode 100644
index 000000000000..b6c1e6fcd36f
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ dev-libs/urdfdom[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"