summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:34:27 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-04 22:34:27 +0300
commit7e8633dd7785512ff05ff27aec540e8e20a6bdcf (patch)
treed8a5ec817ccf1863b754da9b230916a8e9060f9b /dev-ros
parentdev-ros/console_bridge_vendor: use python_has_version inside python_check_deps (diff)
downloadgentoo-7e8633dd7785512ff05ff27aec540e8e20a6bdcf.tar.gz
gentoo-7e8633dd7785512ff05ff27aec540e8e20a6bdcf.tar.bz2
gentoo-7e8633dd7785512ff05ff27aec540e8e20a6bdcf.zip
dev-ros/poco_vendor: use python_has_version inside python_check_deps
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild4
-rw-r--r--dev-ros/poco_vendor/poco_vendor-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild b/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild
index 09425e587d23..03365083ddf5 100644
--- a/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild
+++ b/dev-ros/poco_vendor/poco_vendor-1.2.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -33,5 +33,5 @@ BDEPEND="
"
python_check_deps() {
- has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+ python_has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
}
diff --git a/dev-ros/poco_vendor/poco_vendor-9999.ebuild b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
index 24ec7a182e2a..6efe66ba9201 100644
--- a/dev-ros/poco_vendor/poco_vendor-9999.ebuild
+++ b/dev-ros/poco_vendor/poco_vendor-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,7 +41,7 @@ BDEPEND="
"
python_check_deps() {
- has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
+ python_has_version "ros-meta/ament_cmake[${PYTHON_USEDEP}]"
}
src_configure() {