summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-07 06:59:21 +0100
committerSam James <sam@gentoo.org>2023-04-07 12:24:45 +0100
commite1dc1bc1c6ea3b707dc8279c425588af3eee161b (patch)
tree494901fb82fcbf2a0194ed37b69612ec450cdc3f /dev-ruby/activejob
parentdev-ruby/actionview: enable ruby32 for 7.0.x (diff)
downloadgentoo-e1dc1bc1c6ea3b707dc8279c425588af3eee161b.tar.gz
gentoo-e1dc1bc1c6ea3b707dc8279c425588af3eee161b.tar.bz2
gentoo-e1dc1bc1c6ea3b707dc8279c425588af3eee161b.zip
dev-ruby/activejob: enable ruby32 for 7.0.x
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/activejob')
-rw-r--r--dev-ruby/activejob/activejob-7.0.4.3-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ruby/activejob/activejob-7.0.4.3-r1.ebuild b/dev-ruby/activejob/activejob-7.0.4.3-r1.ebuild
new file mode 100644
index 000000000000..749ad1c8eb29
--- /dev/null
+++ b/dev-ruby/activejob/activejob-7.0.4.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Job framework with pluggable queues"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/globalid-0.3.6
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/mocha
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ sed -i -e '/load_paths/d' test/helper.rb || die "Unable to remove load paths"
+
+ # Remove all currently unpackaged queues.
+ sed -i -e 's/que queue_classic resque sidekiq sneakers sucker_punch backburner//' \
+ -e 's/delayed_job//' Rakefile || die
+ sed -i -e '/SneakersAdapter/ s:^:#:' test/cases/exceptions_test.rb || die
+ rm -f test/cases/delayed_job_adapter_test.rb || die
+}