summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/akismet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/akismet')
-rw-r--r--dev-ruby/akismet/Manifest2
-rw-r--r--dev-ruby/akismet/akismet-1.0.2.ebuild19
-rw-r--r--dev-ruby/akismet/akismet-2.0.0.ebuild22
-rw-r--r--dev-ruby/akismet/metadata.xml8
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/akismet/Manifest b/dev-ruby/akismet/Manifest
new file mode 100644
index 000000000000..4fe6740d99d7
--- /dev/null
+++ b/dev-ruby/akismet/Manifest
@@ -0,0 +1,2 @@
+DIST akismet-1.0.2.tar.gz 5567 SHA256 ddbbed326fb959aa85f8f09f11da4d5a2a6f30af7b830d9d15c9f90b582218ef SHA512 1cc5ef894a40c77eedaed3a6f2d1b778df0bb6cdc7d072ce35bd74b6e6871c830c1d83fc7faa85792208e1517723e3144973c7c05b74978476ef9854f8f27b6a WHIRLPOOL 188136b9943e70cb10f269f5bbc9e3cf4f68c6ac8fc9ffc1caf62b5b93b40d5c8c4fc9e089fe5d5cdc74f0c4ffe65c85035ca23147a0a8380de0137861faf295
+DIST akismet-2.0.0.tar.gz 8530 SHA256 e0080ab9e8737645689bd0ebe06d1b939397c74813103d32f69f6b49d7650076 SHA512 24066e88dfe6bd369b362da60677b8e4acc0785c99fd180e38ff0c11a83131dcb98bc22a7dbce5ff99c8841331fff487090c53bf480a787ec30e58ebba86c762 WHIRLPOOL 023e27aee98c90ef200db061b9fbd162fc74b417fac9f0aee8fd3484392cecf349e1abf7b51ad619fdb97ed2f05f0c121d854d771f8682d4bad2020f3bf9743b
diff --git a/dev-ruby/akismet/akismet-1.0.2.ebuild b/dev-ruby/akismet/akismet-1.0.2.ebuild
new file mode 100644
index 000000000000..c8a1d5d1c0ec
--- /dev/null
+++ b/dev-ruby/akismet/akismet-1.0.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby client for the Akismet API"
+HOMEPAGE="https://github.com/jonahb/akismet"
+SRC_URI="https://github.com/jonahb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
diff --git a/dev-ruby/akismet/akismet-2.0.0.ebuild b/dev-ruby/akismet/akismet-2.0.0.ebuild
new file mode 100644
index 000000000000..a446114eff44
--- /dev/null
+++ b/dev-ruby/akismet/akismet-2.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby client for the Akismet API"
+HOMEPAGE="https://github.com/jonahb/akismet"
+SRC_URI="https://github.com/jonahb/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+# Tests now require an API key from akismet and a network connection.
+RESTRICT="test"
diff --git a/dev-ruby/akismet/metadata.xml b/dev-ruby/akismet/metadata.xml
new file mode 100644
index 000000000000..fb80028858a0
--- /dev/null
+++ b/dev-ruby/akismet/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">jonahb/akismet</remote-id>
+ </upstream>
+</pkgmetadata>