summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-10 08:51:57 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-10 08:51:57 +0200
commitde3681a8f7fbb7943245097145103c4caecb7d5c (patch)
treed4d6571db35552d1e4d6b617ef0a6d25861486f1 /dev-ruby/asciidoctor-diagram
parentdev-ruby/rails: add 7.0.8 (diff)
downloadgentoo-de3681a8f7fbb7943245097145103c4caecb7d5c.tar.gz
gentoo-de3681a8f7fbb7943245097145103c4caecb7d5c.tar.bz2
gentoo-de3681a8f7fbb7943245097145103c4caecb7d5c.zip
dev-ruby/asciidoctor-diagram: add 2.2.12
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/asciidoctor-diagram')
-rw-r--r--dev-ruby/asciidoctor-diagram/Manifest1
-rw-r--r--dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.12.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor-diagram/Manifest b/dev-ruby/asciidoctor-diagram/Manifest
index c3712f2db557..b0e004244e5d 100644
--- a/dev-ruby/asciidoctor-diagram/Manifest
+++ b/dev-ruby/asciidoctor-diagram/Manifest
@@ -1,2 +1,3 @@
DIST asciidoctor-diagram-2.0.5.tar.gz 12482984 BLAKE2B b0ef8596d2f2dfcf11fcbba876141aee38e8615195159f76e07b45c00b46bd85824dd6e8e9f571b396bbd9d082c5d60d4e05cdeac27719bfca53216c0d1b1816 SHA512 7e3bfbfb08d7389a039b1727bc173fca82e05134bebd89f3ca65d5e7860555034ff5e785c32e55ea2cc9826343456c6ecdfa15fc76f4d94858461356ab3ced71
DIST asciidoctor-diagram-2.2.11.tar.gz 15488606 BLAKE2B e0080ecafafcaef72ae1ca449d4ea2d4b69b1550d62cacb514350da047952adbddc0c9f48081fe7acae7f174c6b910c297357ef57df09c0c5a379a3332eb38e8 SHA512 233d2940516fa28863e53b7e4f43851256fdcc83e92fc5d4eafdc2e820a8040473c89f7f01397bdb26b6c4fbd9e6fcb576156c4abd949660ade37d152c8e5e40
+DIST asciidoctor-diagram-2.2.12.tar.gz 14093006 BLAKE2B 2f2349c6694c35ea74bfc74e145eb2f34a422354e1ad4bc87b23bda66443ced7b14ccbce3b015d545fd84d89a6aee44c0c98743b9410c0a460571c83ca1c03ca SHA512 0a960a0f48bd1c129b218f0b70686f7d2f5745f84e484e3152e2532c51bf2987bbefec4cef06d579de1c881545ecdc34a607a00ad1af09ed748c7c66571570ac
diff --git a/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.12.ebuild b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.12.ebuild
new file mode 100644
index 000000000000..cb24f379e007
--- /dev/null
+++ b/dev-ruby/asciidoctor-diagram/asciidoctor-diagram-2.2.12.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc LICENSE.txt README.adoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A set of Asciidoctor extensions that enable you to add diagrams"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor-diagram"
+SRC_URI="https://github.com/asciidoctor/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" virtual/jre"
+DEPEND+=" test? (
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ media-gfx/imagemagick[png,postscript]
+ media-gfx/graphviz
+ media-sound/lilypond
+ sci-visualization/gnuplot
+)"
+ruby_add_rdepend ">=dev-ruby/asciidoctor-1.5.7 <dev-ruby/asciidoctor-3"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/c.formatter/ s:^:#:' \
+ -e '/logger.*DEBUG/ s:^:#:' \
+ -i spec/test_helper_methods.rb || die
+
+ # Remove some diagram dependencies that contains vendored code and
+ # are currently not packaged. Please file a bug if you have a need
+ # for these diagram types.
+ sed -i -e '/\(ditaamini\|plantuml\)/ s:^:#:' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid specs for unpackaged tools
+ rm -f spec/{a2s,barcode,blockdiag,bpmn,bytefield,d2,dbml,diagrams,ditaa,dpic,erd,graphviz_py,mermaid,msc,nomnoml,pikchr,plantuml,shaape,smcat,structurizr,svgbob,symbolator,syntrax,umlet,vega,wavedrom}_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+}