summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-09-01 20:36:40 +0200
committerHans de Graaff <graaff@gentoo.org>2016-09-01 21:49:34 +0200
commit092dbb67d0c499084418e04a7c66c8b5106fffe4 (patch)
tree40a28764c16e85e6eca58308bea6634745838e62 /dev-ruby/childprocess
parentapp-admin/lastpass-cli: version bump to 1.0.0 (diff)
downloadgentoo-092dbb67d0c499084418e04a7c66c8b5106fffe4.tar.gz
gentoo-092dbb67d0c499084418e04a7c66c8b5106fffe4.tar.bz2
gentoo-092dbb67d0c499084418e04a7c66c8b5106fffe4.zip
dev-ruby/childprocess: add ruby23 revision
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/childprocess')
-rw-r--r--dev-ruby/childprocess/childprocess-0.5.9-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/childprocess/childprocess-0.5.9-r1.ebuild b/dev-ruby/childprocess/childprocess-0.5.9-r1.ebuild
new file mode 100644
index 000000000000..456c2d10a292
--- /dev/null
+++ b/dev-ruby/childprocess/childprocess-0.5.9-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Solution for controlling external programs running in the background"
+HOMEPAGE="https://github.com/jarib/childprocess"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard dev-ruby/rspec:3 )"
+
+ruby_add_rdepend ">=dev-ruby/ffi-1.0.11"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ rm Gemfile || die
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/[Cc]overalls/d" spec/spec_helper.rb || die
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}