summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/facets
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/facets')
-rw-r--r--dev-ruby/facets/Manifest1
-rw-r--r--dev-ruby/facets/facets-2.9.3.ebuild39
-rw-r--r--dev-ruby/facets/metadata.xml5
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/facets/Manifest b/dev-ruby/facets/Manifest
new file mode 100644
index 000000000000..dd93e978a084
--- /dev/null
+++ b/dev-ruby/facets/Manifest
@@ -0,0 +1 @@
+DIST facets-2.9.3.gem 287232 SHA256 2ccc1c0a305adf294054a8c53581dc20812b1f9feea412d0e11cd1812bfa75dd SHA512 58181e4641dbddb6b3cda76adc024f945afcae90d3d37b0b1f82b31171244d7cbc3b759509b96002e4c4fd9a56fe3696f9dabb9541ecdf44374bb307aee3c11d WHIRLPOOL 7da1018b452c698c42e3faf3ccd5080e095a826c4031292131913c1bb29baaa6e6d69ce4bc0376ab14e4febf270a6f4ea13222632b1977703479a718355cd26a
diff --git a/dev-ruby/facets/facets-2.9.3.ebuild b/dev-ruby/facets/facets-2.9.3.ebuild
new file mode 100644
index 000000000000..926bd2ded3b3
--- /dev/null
+++ b/dev-ruby/facets/facets-2.9.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Facets is the premier collection of extension methods for Ruby"
+HOMEPAGE="https://rubyworks.github.io/facets/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/ae
+ dev-ruby/lemon
+ dev-ruby/rubytest
+ dev-ruby/rubytest-cli )"
+
+all_ruby_prepare() {
+
+ # Tests need to write to tmp/
+ mkdir tmp/ || die 'mkdir failed'
+
+ # See TODO: https://github.com/rubyworks/facets/blob/2.9.3/test/core/kernel/test_source_location.rb
+ rm test/core/kernel/test_source_location.rb || die 'test removal failed'
+}
+
+each_ruby_test() {
+ ${RUBY} -S rubytest -r lemon -r ae -Ilib/core -Ilib/standard -Itest test/ || die 'tests failed'
+}
diff --git a/dev-ruby/facets/metadata.xml b/dev-ruby/facets/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/facets/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>