summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-09 06:34:31 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-09 06:34:31 +0200
commit0875f3cca2ab11d3c5bedaecf283ad91508ce8bb (patch)
tree3b9a74c64eb53352ebac169ba2af94b4febb1c09 /dev-ruby/gherkin
parentdev-ruby/vlad: add ruby24, ruby25 (diff)
downloadgentoo-0875f3cca2ab11d3c5bedaecf283ad91508ce8bb.tar.gz
gentoo-0875f3cca2ab11d3c5bedaecf283ad91508ce8bb.tar.bz2
gentoo-0875f3cca2ab11d3c5bedaecf283ad91508ce8bb.zip
dev-ruby/gherkin: cleanup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/Manifest1
-rw-r--r--dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild95
2 files changed, 0 insertions, 96 deletions
diff --git a/dev-ruby/gherkin/Manifest b/dev-ruby/gherkin/Manifest
index dd898708a14a..ca7423e0254e 100644
--- a/dev-ruby/gherkin/Manifest
+++ b/dev-ruby/gherkin/Manifest
@@ -1,4 +1,3 @@
-DIST gherkin-2.12.0-git.tgz 605964 BLAKE2B 035f3ce3541010d42351b728c4452befa4939da0216b059d3895f5677e4bffa2a40b389e21292d0051a3126064d137e5e0f2c7bd030e42a8c4ab38cbd4a7f7f2 SHA512 e86c2299bb3b41845bf8a3119b65ff855023510173b04c1e08e1105c03523e0e89ec45db4c7034e85fc20b7a9e1ce5a791aaf3f4793d44c0aa782ffd9fcee83a
DIST gherkin-2.12.2-git.tgz 1764938 BLAKE2B b5cc7f063c8567df2dfe92fe805d5310feeba967865221ce69c8c24986ab786851885f4724b17a028daea298eea340b3bcd0c7296f05b02816c837ffdf8a41b5 SHA512 1030bcaf31791c7031f22b8e4c5d94ddbddf012b8686d06a7598fde99a28f8a1fda45dc66dbdefdb825a045730b077a10ca1134835630710551e20364886ce51
DIST gherkin-4.1.3.gem 350208 BLAKE2B 3b0f54124c9f29c9216aaa9810526f1e11f6243b02143443d0ac18209320c14fda67f1c36d3056dbe5adbc18c36f72270054c17a011921eb87f8d21bc3e8c3c9 SHA512 7c113172ddf38ccf7e49eaac19355f3cb991f69d7499dba9189f375b75d3614f349fc6374e584a92c1223b0708cc8944859b4b38e28d79779a5091fa0c775e6e
DIST gherkin-5.0.0.gem 340992 BLAKE2B a8292fde04c98c409423733791e78b9d6e40a7a60b59a1acd0a0e9c6df0be9185e90f1c5af6ce0ac39f352457c18094c495557fb05323eb7ea5ae8ce27008950 SHA512 cc782e37f5aea4ad0776f5336e6218b77e7fd8d193786acffaa44685de3a2592e4e6f37a3787add807654901afd12bc2d094a782b154bb2be9e2cd16e283df2a
diff --git a/dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild b/dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild
deleted file mode 100644
index 77bb691d3a12..000000000000
--- a/dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel"
-HOMEPAGE="https://github.com/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc ppc64 ~sparc x86"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} =dev-util/ragel-6*"
-RDEPEND="${RDEPEND}"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.1.3
- >=dev-ruby/rspec-2.6.0:2
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.8.3 )"
-
-ruby_add_rdepend ">=dev-ruby/multi_json-1.3"
-
-RUBY_PATCHES=( ${P}-ruby21.patch )
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Keep this hardcoded -O0 optimization level since
- # https://github.com/cucumber/gherkin/issues/182#issuecomment-6945009
- # hints at the fact that removing it might cause the mysterious
- # Lexer errors that hapen intermittently.
- # sed -ie -e 's/-O0//' tasks/compile.rake || die
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-
- # Avoid dependency on yard if USE=-doc
- if ! use doc ; then
- rm tasks/apidoc.rake || die
- fi
-
- # Avoid implicit dependency on git
- sed -i -e 's/git ls-files/echo/' gherkin.gemspec || die
-
- # Fix deprecated code removed in ruby22
- sed -i -e 's/Config/RbConfig/' tasks/ragel_task.rb || die
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use doc ; then
- yard || die
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rspec-2 spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}