summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/gherkin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/Manifest2
-rw-r--r--dev-ruby/gherkin/files/gherkin-2.12.0-ruby21.patch42
-rw-r--r--dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch44
-rw-r--r--dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild91
-rw-r--r--dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild96
-rw-r--r--dev-ruby/gherkin/gherkin-2.12.2.ebuild94
-rw-r--r--dev-ruby/gherkin/metadata.xml8
7 files changed, 377 insertions, 0 deletions
diff --git a/dev-ruby/gherkin/Manifest b/dev-ruby/gherkin/Manifest
new file mode 100644
index 000000000000..8625a5a10212
--- /dev/null
+++ b/dev-ruby/gherkin/Manifest
@@ -0,0 +1,2 @@
+DIST gherkin-2.12.0-git.tgz 605964 SHA256 09206d66e437bfa2cb917a251899e3e95479c47d713a2b8de3e7dcbdd9982bfa SHA512 e86c2299bb3b41845bf8a3119b65ff855023510173b04c1e08e1105c03523e0e89ec45db4c7034e85fc20b7a9e1ce5a791aaf3f4793d44c0aa782ffd9fcee83a WHIRLPOOL dcfc5b5a0dcad7e401c2e0afb41e53593d095a44e97df8eadffa634b155ccb5a979f3e719e57c32d18afac0be49d31021276abc20010a6a9259ca041c155a390
+DIST gherkin-2.12.2-git.tgz 1764938 SHA256 139739eae42c7da925c816c859a41dcf539a361040ffb64c174e90e3fd9425b9 SHA512 1030bcaf31791c7031f22b8e4c5d94ddbddf012b8686d06a7598fde99a28f8a1fda45dc66dbdefdb825a045730b077a10ca1134835630710551e20364886ce51 WHIRLPOOL b5bdcff4a1e8e8ff32c202cac4e33ba9f07dac09ad723b9b6ef202dfa6a86413aff4e5fe24c69962edccf24158c9c85e8d32fc75a92ee0243943dff04327fe7c
diff --git a/dev-ruby/gherkin/files/gherkin-2.12.0-ruby21.patch b/dev-ruby/gherkin/files/gherkin-2.12.0-ruby21.patch
new file mode 100644
index 000000000000..8931c5dce8e5
--- /dev/null
+++ b/dev-ruby/gherkin/files/gherkin-2.12.0-ruby21.patch
@@ -0,0 +1,42 @@
+commit 021309d273960bb5625f8072b8366eab7d077d25
+Author: Cédric Boutillier <boutil@debian.org>
+Date: Fri Apr 25 13:34:41 2014 +0200
+
+ change regexp matchin Ruby versions to support Ruby2.1
+
+diff --git a/lib/gherkin/formatter/pretty_formatter.rb b/lib/gherkin/formatter/pretty_formatter.rb
+index 28c8b54..ff13c70 100644
+--- a/lib/gherkin/formatter/pretty_formatter.rb
++++ b/lib/gherkin/formatter/pretty_formatter.rb
+@@ -199,7 +199,7 @@ module Gherkin
+ end
+ end
+
+- if(RUBY_VERSION =~ /^1\.9|2\.0/)
++ if(RUBY_VERSION =~ /^(1\.9|2\.)/)
+ START = /#{'^'.encode('UTF-8')}/
+ TRIPLE_QUOTES = /#{'"""'.encode('UTF-8')}/
+ else
+diff --git a/ragel/lexer.rb.rl.erb b/ragel/lexer.rb.rl.erb
+index 7fd85b4..4be053e 100644
+--- a/ragel/lexer.rb.rl.erb
++++ b/ragel/lexer.rb.rl.erb
+@@ -165,7 +165,7 @@ module Gherkin
+ utf8_pack(rest[0..rest.index(10)||-1]).strip # 10 is \n
+ end
+
+- if (RUBY_VERSION =~ /^1\.9|2\.0/)
++ if (RUBY_VERSION =~ /^(1\.9|2\.)/)
+ def utf8_pack(array)
+ array.pack("c*").force_encoding("UTF-8")
+ end
+diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
+index 72333a7..0f6e3ae 100644
+--- a/spec/spec_helper.rb
++++ b/spec/spec_helper.rb
+@@ -6,4 +6,4 @@ def silence_warnings(&block)
+-if RUBY_VERSION =~ /1\.9|2\.0/
++if RUBY_VERSION =~ /^(1\.9|2\.)/
+ Encoding.default_external = Encoding::UTF_8
+ Encoding.default_internal = Encoding::UTF_8
+ end
diff --git a/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch b/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch
new file mode 100644
index 000000000000..f767b1f1a2e4
--- /dev/null
+++ b/dev-ruby/gherkin/files/gherkin-2.12.2-ruby21.patch
@@ -0,0 +1,44 @@
+commit 021309d273960bb5625f8072b8366eab7d077d25
+Author: Cédric Boutillier <boutil@debian.org>
+Date: Fri Apr 25 13:34:41 2014 +0200
+
+ change regexp matchin Ruby versions to support Ruby2.1
+
+diff --git a/lib/gherkin/formatter/pretty_formatter.rb b/lib/gherkin/formatter/pretty_formatter.rb
+index 28c8b54..ff13c70 100644
+--- a/lib/gherkin/formatter/pretty_formatter.rb
++++ b/lib/gherkin/formatter/pretty_formatter.rb
+@@ -199,7 +199,7 @@ module Gherkin
+ end
+ end
+
+- if(RUBY_VERSION =~ /^1\.9|2\.0/)
++ if(RUBY_VERSION =~ /^(1\.9|2\.)/)
+ START = /#{'^'.encode('UTF-8')}/
+ TRIPLE_QUOTES = /#{'"""'.encode('UTF-8')}/
+ else
+diff --git a/ragel/lexer.rb.rl.erb b/ragel/lexer.rb.rl.erb
+index 7fd85b4..4be053e 100644
+--- a/ragel/lexer.rb.rl.erb
++++ b/ragel/lexer.rb.rl.erb
+@@ -165,7 +165,7 @@ module Gherkin
+ utf8_pack(rest[0..rest.index(10)||-1]).strip # 10 is \n
+ end
+
+- if (RUBY_VERSION =~ /^1\.9|2\.0/)
++ if (RUBY_VERSION =~ /^(1\.9|2\.)/)
+ def utf8_pack(array)
+ array.pack("c*").force_encoding("UTF-8")
+ end
+diff --git a/spec/spec_helper.rb b/spec/spec_helper.rb
+index 72333a7..0f6e3ae 100644
+--- a/spec/spec_helper.rb
++++ b/spec/spec_helper.rb
+@@ -6,6 +6,6 @@ def silence_warnings(&block)
+-if RUBY_VERSION =~ /1\.9|2\.0/
++if RUBY_VERSION =~ /^(1\.9|2\.)/
+ silence_warnings do
+ Encoding.default_external = Encoding::UTF_8
+ Encoding.default_internal = Encoding::UTF_8
+ end
+ end
diff --git a/dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild b/dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild
new file mode 100644
index 000000000000..79414095d696
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.12.0-r2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel"
+HOMEPAGE="https://github.com/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-1.1.3
+ >=dev-ruby/rspec-2.6.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )
+ doc? ( >=dev-ruby/yard-0.8.3 )"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.3"
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Keep this hardcoded -O0 optimization level since
+ # https://github.com/cucumber/gherkin/issues/182#issuecomment-6945009
+ # hints at the fact that removing it might cause the mysterious
+ # Lexer errors that hapen intermittently.
+ # sed -ie -e 's/-O0//' tasks/compile.rake || die
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove these tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet. Also remove other rake tasks for which we may not yet have
+ # dependencies.
+ if ! use test ; then
+ rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
+ fi
+
+ # Avoid dependency on yard if USE=-doc
+ if ! use doc ; then
+ rm tasks/apidoc.rake || die
+ fi
+
+ # Avoid implicit dependency on git
+ sed -i -e 's/git ls-files/echo/' gherkin.gemspec || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rake spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
+}
diff --git a/dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild b/dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild
new file mode 100644
index 000000000000..158c8a1407f4
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.12.0-r3.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel"
+HOMEPAGE="https://github.com/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ test? (
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-1.1.3
+ >=dev-ruby/rspec-2.6.0:2
+ >=dev-ruby/term-ansicolor-1.0.5
+ )
+ doc? ( >=dev-ruby/yard-0.8.3 )"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.3"
+
+RUBY_PATCHES=( ${P}-ruby21.patch )
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Keep this hardcoded -O0 optimization level since
+ # https://github.com/cucumber/gherkin/issues/182#issuecomment-6945009
+ # hints at the fact that removing it might cause the mysterious
+ # Lexer errors that hapen intermittently.
+ # sed -ie -e 's/-O0//' tasks/compile.rake || die
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove these tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet. Also remove other rake tasks for which we may not yet have
+ # dependencies.
+ if ! use test ; then
+ rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
+ fi
+
+ # Avoid dependency on yard if USE=-doc
+ if ! use doc ; then
+ rm tasks/apidoc.rake || die
+ fi
+
+ # Avoid implicit dependency on git
+ sed -i -e 's/git ls-files/echo/' gherkin.gemspec || die
+
+ # Fix deprecated code removed in ruby22
+ sed -i -e 's/Config/RbConfig/' tasks/ragel_task.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rspec-2 spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
+}
diff --git a/dev-ruby/gherkin/gherkin-2.12.2.ebuild b/dev-ruby/gherkin/gherkin-2.12.2.ebuild
new file mode 100644
index 000000000000..a984e14afdd7
--- /dev/null
+++ b/dev-ruby/gherkin/gherkin-2.12.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="History.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast Gherkin lexer and parser based on Ragel"
+HOMEPAGE="https://github.com/cucumber/gherkin"
+LICENSE="MIT"
+SRC_URI="https://github.com/cucumber/gherkin/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+SLOT="0"
+IUSE="doc test"
+
+DEPEND="${DEPEND} dev-util/ragel"
+RDEPEND="${RDEPEND}"
+
+ruby_add_bdepend "
+ dev-ruby/rake-compiler
+ dev-ruby/ruby-beautify
+ test? (
+ >=dev-ruby/builder-2.1.2
+ >=dev-util/cucumber-1.1.3
+ >=dev-ruby/rspec-2.6.0
+ >=dev-ruby/term-ansicolor-1.0.5
+ )
+ doc? ( >=dev-ruby/yard-0.8.3 )"
+
+ruby_add_rdepend ">=dev-ruby/multi_json-1.3"
+
+RUBY_PATCHES=( ${P}-ruby21.patch )
+
+all_ruby_prepare() {
+ # Remove Bundler-related things.
+ sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
+ rm Gemfile || die
+
+ # Don't use compile dependencies to avoid building again for specs.
+ sed -i -e '/:compile/d' Rakefile
+
+ # Keep this hardcoded -O0 optimization level since
+ # https://github.com/cucumber/gherkin/issues/182#issuecomment-6945009
+ # hints at the fact that removing it might cause the mysterious
+ # Lexer errors that hapen intermittently.
+ # sed -ie -e 's/-O0//' tasks/compile.rake || die
+
+ # Remove feature that depends on direct access to the cucumber
+ # source. We could probably set this up by downloading the source
+ # and unpacking it, but skipping this now in the interest of time.
+ rm features/pretty_formatter.feature || die
+
+ # We need to remove these tasks during bootstrapping since it tries
+ # to load cucumber already but we can be sure it isn't installed
+ # yet. Also remove other rake tasks for which we may not yet have
+ # dependencies.
+ if ! use test ; then
+ rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
+ fi
+
+ # Avoid dependency on yard if USE=-doc
+ if ! use doc ; then
+ rm tasks/apidoc.rake || die
+ fi
+
+ # Avoid implicit dependency on git
+ sed -i -e 's/git ls-files/echo/' gherkin.gemspec || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die
+ fi
+}
+
+each_ruby_compile() {
+ ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -I lib -S rspec-2 spec || die "Specs failed"
+ CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
+}
diff --git a/dev-ruby/gherkin/metadata.xml b/dev-ruby/gherkin/metadata.xml
new file mode 100644
index 000000000000..610f535de352
--- /dev/null
+++ b/dev-ruby/gherkin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">cucumber/gherkin</remote-id>
+ </upstream>
+</pkgmetadata>