summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/hashie
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/hashie')
-rw-r--r--dev-ruby/hashie/Manifest4
-rw-r--r--dev-ruby/hashie/hashie-2.1.2-r1.ebuild29
-rw-r--r--dev-ruby/hashie/hashie-2.1.2.ebuild29
-rw-r--r--dev-ruby/hashie/hashie-3.3.2.ebuild31
-rw-r--r--dev-ruby/hashie/hashie-3.4.1.ebuild31
-rw-r--r--dev-ruby/hashie/hashie-3.4.2.ebuild31
-rw-r--r--dev-ruby/hashie/metadata.xml5
7 files changed, 160 insertions, 0 deletions
diff --git a/dev-ruby/hashie/Manifest b/dev-ruby/hashie/Manifest
new file mode 100644
index 000000000000..ea150c267119
--- /dev/null
+++ b/dev-ruby/hashie/Manifest
@@ -0,0 +1,4 @@
+DIST hashie-2.1.2.gem 34816 SHA256 a9e1e4928bf4f5a5683ea9c7ef29e50fb93f72542f9a9550e205fe33a6568923 SHA512 6f72998710da58a2584939b4e74a114ae54168902020dc16ec5ea0422a91316b84aa6835fffb36a2985634f24ff5b0d01bcdb50134a414a269a4881ebcd728ac WHIRLPOOL 6b67c04ef9dc33a9ffdf25d14440bdd3ce621f1bde9b4eb806de63fa39edc76627f80d10435efc708fc48d24f1450046f33aceb20d76238a0cf8b67ddcf72e78
+DIST hashie-3.3.2.gem 48640 SHA256 99fad6bb323e965f72c82f08f86162858b97d9b1a4550cf49c180f211e3291a0 SHA512 22e6a15d70c8dfaebb99564e874640cdce60d3c127841054c38ff2287926f93e5c2d3cade98fb766e69722d442e54276af7dd95575d1bc2800d978f6763149c5 WHIRLPOOL 07fe013d529a13124e8fe9228a728507d0e74fb493677b4ec624a85829942a7a5f0e0d9248080dc6681f619fa5be45cd363218970e3572b83e65630ffd97d7a8
+DIST hashie-3.4.1.gem 54784 SHA256 76dc47a37116e8e6be30e37389776cecd3809efa5e4e207f2d02de0f3d9a4f34 SHA512 9a0e68b0a260cb4387d21284164c0b67fb332860338f773c4368ab4d40aaaececcaa84ea6d92ff391f0914ad7a7aaf3ce54ffbddd1861606035b4021d9a2c197 WHIRLPOOL c81ae5c69f749180838cb1310a99bbea961005ab03d343831f039ec1e855886858c265c24b60946f016c04da5253b9d563298643c9db778be3a01d69cc9950ee
+DIST hashie-3.4.2.gem 56320 SHA256 b68373c5f6589c5222638433918bc3e256acbaead7f883e5ec18420f507b17ca SHA512 9081d91ad014914f59ec4e18b92c27b6f316f03f476c94d3b469bda54f201d339d553ef142018f0e605d3571418af784d57e25211a6c141cd8eb5a56497c28d6 WHIRLPOOL cc76a268a7b8abc618b236a1958db783a5dc9e14c92b719782db71dd1a518e436b4e801f6854e5c8958298d4212814bae23893c1fe2a42561de28ba993847b2f
diff --git a/dev-ruby/hashie/hashie-2.1.2-r1.ebuild b/dev-ruby/hashie/hashie-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..52a568322f4a
--- /dev/null
+++ b/dev-ruby/hashie/hashie-2.1.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '2irequire "hashie/version"' -i spec/hashie/version_spec.rb || die
+}
diff --git a/dev-ruby/hashie/hashie-2.1.2.ebuild b/dev-ruby/hashie/hashie-2.1.2.ebuild
new file mode 100644
index 000000000000..e4143182407f
--- /dev/null
+++ b/dev-ruby/hashie/hashie-2.1.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '2irequire "hashie/version"' -i spec/hashie/version_spec.rb || die
+}
diff --git a/dev-ruby/hashie/hashie-3.3.2.ebuild b/dev-ruby/hashie/hashie-3.3.2.ebuild
new file mode 100644
index 000000000000..8fc819e79e1b
--- /dev/null
+++ b/dev-ruby/hashie/hashie-3.3.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '/pry/ s:^:#:' -i spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/hashie/hashie-3.4.1.ebuild b/dev-ruby/hashie/hashie-3.4.1.ebuild
new file mode 100644
index 000000000000..8fc819e79e1b
--- /dev/null
+++ b/dev-ruby/hashie/hashie-3.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '/pry/ s:^:#:' -i spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/hashie/hashie-3.4.2.ebuild b/dev-ruby/hashie/hashie-3.4.2.ebuild
new file mode 100644
index 000000000000..d65b458c1fdd
--- /dev/null
+++ b/dev-ruby/hashie/hashie-3.4.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="http://intridea.com/posts/hashie-the-hash-toolkit"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '/pry/ s:^:#:' -i spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/hashie/metadata.xml b/dev-ruby/hashie/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/hashie/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>