summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-10 16:05:48 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-10 21:29:08 +0100
commit1d46b4d8ae519fe5ec93e5eb2daa0f2009da6404 (patch)
tree397175639d9849ad4b424dd4c6145e5c2db75fb3 /dev-ruby/nanotest
parentdev-ruby/unf_ext: enable ruby32 (diff)
downloadgentoo-1d46b4d8ae519fe5ec93e5eb2daa0f2009da6404.tar.gz
gentoo-1d46b4d8ae519fe5ec93e5eb2daa0f2009da6404.tar.bz2
gentoo-1d46b4d8ae519fe5ec93e5eb2daa0f2009da6404.zip
dev-ruby/nanotest: update EAPI 7 -> 8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/nanotest')
-rw-r--r--dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild b/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
new file mode 100644
index 000000000000..87113b2ee759
--- /dev/null
+++ b/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extremely mynymal test framework"
+HOMEPAGE="https://github.com/mynyml/nanotest"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_nanotest.rb || die
+}