summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-02 09:36:26 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-03 08:32:05 +0100
commit6063f84baa306e46b4817a1fca8dadd071ac251b (patch)
treed43b60d697e04eb0d8822e41e5bcfe16e7d0a4e0 /dev-ruby/nanotest
parentdev-util/cucumber-tag-expressions: enable ruby33 (diff)
downloadgentoo-6063f84baa306e46b4817a1fca8dadd071ac251b.tar.gz
gentoo-6063f84baa306e46b4817a1fca8dadd071ac251b.tar.bz2
gentoo-6063f84baa306e46b4817a1fca8dadd071ac251b.zip
dev-ruby/nanotest: enable ruby33
Fix deprecated and removed Minitest syntax. Closes: https://bugs.gentoo.org/911959 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/nanotest')
-rw-r--r--dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild b/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
index 7f7fa0d47fe6..463f215eb6d8 100644
--- a/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
+++ b/dev-ruby/nanotest/nanotest-0.9.4.1-r2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+USE_RUBY="ruby31 ruby32 ruby33"
RUBY_FAKEGEM_EXTRADOC="README.md"
@@ -14,7 +14,14 @@ LICENSE="MIT"
KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
SLOT="0"
-IUSE=""
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -e 's/MiniTest::Unit::TestCase/Minitest::Test/' \
+ -i test/test_helper.rb test/test_nanotest.rb || die
+}
each_ruby_test() {
${RUBY} -I.:lib test/test_nanotest.rb || die