summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-07-11 07:18:46 +0200
committerHans de Graaff <graaff@gentoo.org>2023-07-11 09:47:14 +0200
commitcf3ddb4e91c0f1468c0a835b14d84cb996587f28 (patch)
tree777d0db9a7224e73992223e182d331cad34a4f1a /dev-ruby/patron
parentdev-ruby/pcaprub: enable ruby32 (diff)
downloadgentoo-cf3ddb4e91c0f1468c0a835b14d84cb996587f28.tar.gz
gentoo-cf3ddb4e91c0f1468c0a835b14d84cb996587f28.tar.bz2
gentoo-cf3ddb4e91c0f1468c0a835b14d84cb996587f28.zip
dev-ruby/patron: fix tests
Closes: https://bugs.gentoo.org/892625 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/patron-0.13.3-r2.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-ruby/patron/patron-0.13.3-r2.ebuild b/dev-ruby/patron/patron-0.13.3-r2.ebuild
index 8eeeee2ce837..2665afcbfd35 100644
--- a/dev-ruby/patron/patron-0.13.3-r2.ebuild
+++ b/dev-ruby/patron/patron-0.13.3-r2.ebuild
@@ -24,7 +24,7 @@ IUSE=""
DEPEND+=" net-misc/curl"
RDEPEND+=" net-misc/curl"
-ruby_add_bdepend "test? ( dev-ruby/rack www-servers/puma )"
+ruby_add_bdepend "test? ( dev-ruby/rack:2.2 www-servers/puma )"
all_ruby_prepare() {
# Fix Rakefile
@@ -37,4 +37,7 @@ all_ruby_prepare() {
# Avoid specs with failures. We were not running any specs before.
rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+
+ # Ensure a compatible rack version
+ sed -i -e '1igem "rack", "~> 2.2.0"' spec/spec_helper.rb || die
}