summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-06-14 06:28:23 +0200
committerHans de Graaff <graaff@gentoo.org>2016-06-14 06:51:09 +0200
commitf76bfe4a42f00831806a847378d00e2a745ff32e (patch)
treea4eb2c37490da1841e44e415d4cc0fc624cef1c7 /dev-ruby/patron
parentdev-ruby/hoe-seattlerb: add 1.3.5. (diff)
downloadgentoo-f76bfe4a42f00831806a847378d00e2a745ff32e.tar.gz
gentoo-f76bfe4a42f00831806a847378d00e2a745ff32e.tar.bz2
gentoo-f76bfe4a42f00831806a847378d00e2a745ff32e.zip
dev-ruby/patron: add 0.6.5
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/Manifest1
-rw-r--r--dev-ruby/patron/patron-0.6.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/patron/Manifest b/dev-ruby/patron/Manifest
index f970f351d3e0..e2a96cf8d313 100644
--- a/dev-ruby/patron/Manifest
+++ b/dev-ruby/patron/Manifest
@@ -5,3 +5,4 @@ DIST patron-0.5.1.gem 45056 SHA256 45776b937ee788343ce4d24817460138989b1a65ad9d8
DIST patron-0.6.0.gem 45568 SHA256 af7c51bd680ad0965ff20d5742579f3f985b4ed8e3a6ecd9b2f4976753ee1eb1 SHA512 5dba0cd4945389b50b747ebc0797b4c1c2d9a1adae6565d9228a72700b15720f9252b4e78c6e52c66159139d0ec621bb3f343e5856bdde05686e019e45ddb30a WHIRLPOOL c8fcf8c8e966f52c739193f6e34eb674f36cf2fb000245ff08be4f2f22306cc9c09a225b584bf851528e1987540b306173a035c26f5d4b6b34a2d16bd50dc918
DIST patron-0.6.3.gem 49664 SHA256 f62786700b3f4cc6a3285fdfbe7eb6c5d0c7847de9df30fbb2fa0acbc356cdea SHA512 ab1d48f7a19265c3dce786da872cb7dcaf181a9f942bc23428a2fbe26c8405a23fe6f0380709bcfe8062dd51e71a22849452df2322130f40306c5042642ab117 WHIRLPOOL 6add22c07987eacbe016b110eec524889665d81e6505d654b72615c967cb1425d1ada78cf09df402e6478107c043467f48e19d5bcb1f5310622b960e10e6ae93
DIST patron-0.6.4.gem 53760 SHA256 32ff389a5f1b805d0b4ae99c27d9b3bed5b0a8054f1aab67611a56d552aa731e SHA512 db8a5068ea7a1d227dba33c54b5a015014015832b1378f1f89a6b02e2effe033bc39ebc94d865e5e46748ac0ce2c561e7c4082ee9cbf648eb4096e8e951c540e WHIRLPOOL 4592df82f082395aaf9f8d173b44614202dc2bedb5eed2c98b0dcf2e11f1d5086bbfa8564817d747bed1a839fff87eeeafbadf26661a9d3ca2696d387f81066e
+DIST patron-0.6.5.gem 54272 SHA256 eb7ec133b4fedb240543fa96061ee52fa9ede2bcf6351d13b5cc057d6fec6935 SHA512 ffb2681b7ca062f78931d288314e563f265c9e584b3cb82af16529e8c9b578cca4d57c6e2afc506562cc946def736814b1da13a2630273551e7bf179786516cc WHIRLPOOL cda9b38b74efc0593de4c89dc4efc91ac1431b12293cd83fee32cd7aff1c85c1fcdc7b8c16f54fb0aa4dacc3901cbb37b3dfa2a9d4dd8b4f1011d1c55965efcd
diff --git a/dev-ruby/patron/patron-0.6.5.ebuild b/dev-ruby/patron/patron-0.6.5.ebuild
new file mode 100644
index 000000000000..14a12a44cf38
--- /dev/null
+++ b/dev-ruby/patron/patron-0.6.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl"
+HOMEPAGE="https://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+all_ruby_prepare() {
+ # Fix Rakefile
+ sed -i -e 's:rake/rdoctask:rdoc/task:' \
+ -e 's/README.txt/README.md/' \
+ -e '/bundler/I s:^:#:' \
+ -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/^end/ s:^:#:' \
+ Rakefile || die
+
+ # Avoid specs with failures. We were not running any specs before.
+ rm spec/session_ssl_spec.rb spec/session_spec.rb spec/response_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}