summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/pdf-core
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/pdf-core')
-rw-r--r--dev-ruby/pdf-core/Manifest3
-rw-r--r--dev-ruby/pdf-core/metadata.xml8
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.5.0.ebuild28
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.5.1.ebuild28
-rw-r--r--dev-ruby/pdf-core/pdf-core-0.6.0.ebuild28
5 files changed, 95 insertions, 0 deletions
diff --git a/dev-ruby/pdf-core/Manifest b/dev-ruby/pdf-core/Manifest
new file mode 100644
index 000000000000..12b9615a94be
--- /dev/null
+++ b/dev-ruby/pdf-core/Manifest
@@ -0,0 +1,3 @@
+DIST pdf-core-0.5.0.gem 43008 SHA256 582c08d26965ab59d2129c34ddb5437300c9a5ecf1138a7cd75f905d590f8686 SHA512 67f4055de49dace03e7272668e79e00def9f2c6ebcd3edfff2a12830e3fd2449037c79202c0d575696cbef8e67da5bc430c17b0d842115e0291ff95f135716e8 WHIRLPOOL d4a060fcd42c018b9a2a11a195e05198c60998be9c3c7d5127293fc8cdd3c13736a54895e96cf9a6c09c56bfbd53d7fc5b7ae6cbd1f904c31e73584d0dd2118d
+DIST pdf-core-0.5.1.gem 43008 SHA256 d2b0761c0c5b6b0c196f22bce184060230db689c1436c996892d26b97d2d083d SHA512 b88025556d04af27117092ad7bf6bf08d3424ade3515815b8d26be1aa63940e956cbd0194f10953439bd51f4f743432b59262c48151132f17e20b5efb2649635 WHIRLPOOL cd9f91568d01634f185cadb1e34384b09dbb9cedae036e75f640a9b6a40ca79b71685c7714d1d868c8383f012808cab065dbc5dc58cae64abc20936024a75c34
+DIST pdf-core-0.6.0.gem 43008 SHA256 5ece7892eb5e28ec08625c895a23cfc790e8f3d5031f25dceb1b018dfd2a49cf SHA512 a6090a17aa570d12b18e501cc6b9f2cfbec30cd497ba7bbf63cc2d13136635c67db906fe1c04caa3a52b5d31008708e9c433872d95bed5742c517028670252c2 WHIRLPOOL 6943b8d2a87e0e20ec812b1d5d69e9c440a2586dd9c6276c0c4aebe8b2a3617a248b8b78d1e89eae73c139e5421fd01f788130ef8e1a10f9fb3a0f109980b8d0
diff --git a/dev-ruby/pdf-core/metadata.xml b/dev-ruby/pdf-core/metadata.xml
new file mode 100644
index 000000000000..d73bab461028
--- /dev/null
+++ b/dev-ruby/pdf-core/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">prawnpdf/pdf-core</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild b/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild
new file mode 100644
index 000000000000..cef30fb379ac
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="http://github.com/prawnpdf/pdf-core/"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1.1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/pdf-core/pdf-core-0.5.1.ebuild b/dev-ruby/pdf-core/pdf-core-0.5.1.ebuild
new file mode 100644
index 000000000000..ed53c9c4987a
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="https://github.com/prawnpdf/pdf-core/"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1.1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/pdf-core/pdf-core-0.6.0.ebuild b/dev-ruby/pdf-core/pdf-core-0.6.0.ebuild
new file mode 100644
index 000000000000..ed53c9c4987a
--- /dev/null
+++ b/dev-ruby/pdf-core/pdf-core-0.6.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements low level PDF features for Prawn"
+HOMEPAGE="https://github.com/prawnpdf/pdf-core/"
+
+LICENSE="|| ( Ruby GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( =dev-ruby/pdf-inspector-1.1*
+ >=dev-ruby/pdf-reader-1.2 =dev-ruby/pdf-reader-1* )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" spec/spec_helper.rb || die
+}