summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/permutation
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/permutation')
-rw-r--r--dev-ruby/permutation/Manifest1
-rw-r--r--dev-ruby/permutation/metadata.xml5
-rw-r--r--dev-ruby/permutation/permutation-0.1.8-r1.ebuild25
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/permutation/Manifest b/dev-ruby/permutation/Manifest
new file mode 100644
index 000000000000..0d8526109d50
--- /dev/null
+++ b/dev-ruby/permutation/Manifest
@@ -0,0 +1 @@
+DIST permutation-0.1.8.gem 18432 SHA256 88ea74d7a85b7c5498147d57185bb46cb5234040e8a8fd594afb2fb7c5e4998d SHA512 78f9679a652d3f18ea4b459aeeceb3e25c912e28b7d9052c523b930e94e841fa84daa329f9ff06a23456cd7ab826f18cea181b85dfcfecbf303747990fa9a582 WHIRLPOOL 4cfde679b46dab3b46be828b5d846e07355aebb3251518469158126941c92ddf1b659511a39b6cf2f4f8ebfe2f85a1414f8966ff34f4342793093efa721e1161
diff --git a/dev-ruby/permutation/metadata.xml b/dev-ruby/permutation/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/permutation/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/permutation/permutation-0.1.8-r1.ebuild b/dev-ruby/permutation/permutation-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..b8b06f152e9b
--- /dev/null
+++ b/dev-ruby/permutation/permutation-0.1.8-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Library to perform different operations with permutations of sequences (strings, arrays, etc.)"
+HOMEPAGE="http://flori.github.com/permutation"
+
+LICENSE="|| ( Ruby-BSD BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test.rb || die
+}