summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-29 07:52:58 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-29 07:52:58 +0100
commitf4aa3174bfcba744e797485cad88cbc47135fb45 (patch)
treefdf12f3ee49e39a84aaa00130e63dbd679986798 /dev-ruby/public_suffix/public_suffix-3.0.1.ebuild
parentapp-admin/puppet: also backport ruby 2.3.6 fix to puppet 5.x (diff)
downloadgentoo-f4aa3174bfcba744e797485cad88cbc47135fb45.tar.gz
gentoo-f4aa3174bfcba744e797485cad88cbc47135fb45.tar.bz2
gentoo-f4aa3174bfcba744e797485cad88cbc47135fb45.zip
avoid need for bundler dependency
Closes: https://bugs.gentoo.org/645972 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/public_suffix/public_suffix-3.0.1.ebuild')
-rw-r--r--dev-ruby/public_suffix/public_suffix-3.0.1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild b/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild
index 0994676f87e0..38e346e0bee5 100644
--- a/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild
+++ b/dev-ruby/public_suffix/public_suffix-3.0.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ ruby_add_bdepend "test? ( dev-ruby/mocha )"
all_ruby_prepare() {
sed -i -e '/rubocop/I s:^:#:' \
- -e '/yardoc/,/CLOBBER.include/ s:^:#:' Rakefile || die
+ -e '/yardoc/,/CLOBBER.include/ s:^:#:' \
+ -e '/bundler/ s:^:#:' Rakefile || die
sed -i -e '/reporters/I s:^:#:' test/test_helper.rb || die
}